This Product Ideas board is currently undergoing updates, but please continue to submit your ideas.

SendGrid block HTML formatting

Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

SendGrid block is a great feature which we unfortunately cannot use as it is now.

It has been mentioned here several times (without response from developers) that formatting is crucial for any emails that are intended for customers. It is OK to have plaintext notifications for ourselves, but if we communicate with a client it produces very poor impression and we have to use other tools to send emails.

In our case we just send confirmation of entries to our students with short instructions how to find us and what documents to prepare. Of course, ideally it would be nice to be able to attach images and documents, but even simple HTML or markdown will be enough for start to highlight important information with bold/colored font and make links to files readable. At the moment it looks like a mess of text and long links to google drive. I’ve tried to use HTML formatting in the email body, but of course it failed.

We’ve created a view that filters relevant entries based on student’s status and we are just 2 clicks away from sending confirmations via SendGrid. But without reasonable formatting we now have to copy-paste the email addresses into another mail service window.

Can Airtabe team tell us if we can expect at least basic formatting in SendGrid block in the observable future?

Many thanks!

5 - Automation Enthusiast
5 - Automation Enthusiast

Each time I try to send emails via the SendGrid app it keeps failing.
It has worked successfully previously, but now it doesn’t. I don’t think I’ve changed anything, and I’m only trying to send to 40 email addresses.
My email is fairly short, only 330 characters (only 50 words). I’ve tried using a new API key but that doesn’t work either.
Does anyone have any ideas on why this could be?
Thanks in advance.

4 - Data Explorer
4 - Data Explorer

Same here! Please fix this @Airtable :pray: