Airtable block CLI Not Working on Apple Silicon Macs

I’ve read in this thread that the Airtable block CLI requires Node versions below 15. Unfortunately, I’m on an Apple Silicon Mac trying to help my fellow developer with a custom app project. As it turns out, as far as I can tell, Node 15 is the minimum that builds on Apple’s arm64 architecture. This in effect means that until block is updated to support Node 15, I cannot help build custom apps. I have tried installing older versions of Node with NVM, and they fail to build. Is there any way that I can use block with Node 15, or any idea of the timeline for it to be ready?

I would try using an older version of Node (using nvm) on Apple Silicon using a Terminal with Rosetta 2.

While that ought to work, and so I may try that, it is not a permanent solution. The real solution is the block command gaining Node 15 support, so I was wondering if anyone had a better sense of that timeline. I can run a command line via Rosetta 2, I just don’t consider that a great solution. Partly, in this case, that is because my VS Code is native ARM, and really its integrated terminal is where I’d need block most. So while your suggestion is a valid workaround, I’d rather find a way to run this natively.

Actually, great news. Turns out that you only need to run a command line under Rosetta 2 to install the Node version. But once I did that, running block from VS Code (Apple Silicon-only Insiders build) seems to work fine.

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.