Condition in Conditional Action not working

Hi,

I am creating an automation that will have several conditional Actions, but I can’t seem to get past the first condition. My trigger is a view, and when I test my trigger I can see the specific field I want to use in my action condition, but when I test the condition I get an error. Here are the details:

  • The field that I want to use in my condition is a formula field and contains text, e.g. “John Doe”, and I see this value “John Doe” when examining the result of testing my trigger. The name of this field is “Account Lead”

  • I have no actions that run for all records

  • While setting up my first conditional action, I set my condition as “If ‘Account Lead’ is John Doe” where I select the field ‘Account Lead’ from the trigger action, and type in “John Doe”. I have also tried using “contains” instead of “is” but I get the same failed result.

  • When I test this condition, I selected “Use input from previous steps”, and click “Test Conditions”. I get the message in red “An error occurred while evaluating the condition”. Without any more detail, I can’t figure out why this fails.

I appreciate any help sent my way!

I’m having exactly the same issue! Were you able to solve it?

Hi Susie, sorry I forgot to post the solution I figured out. The field I was trying to use in the condition was a formula field, but it just didn’t seem to work. As an alternative, I made a change so that I could get the same value that was in my formula from another table that was linked. I used a Lookup field to pull that value into the table I’m running the automation on. The condition for my Conditional action seemed to like the Lookup field better than the formula.

1 Like

Hi Sharon, thanks for getting back to me so quickly. Unfortunately I’ve tried both formula fields and lookup fields and the conditional action doesn’t seem to like either.

I’m using the “contains” operator and the text is definitely the same. Is it definitely the “value” of the lookup field that you’re using as the property to search in?

I’m stumped!

I’m using “contains” and the value. Here is a screenshot (if it uploads):
image

How strange, that is exactly what I’m doing.

I’ve had to use 3 different automations instead, as I just can’t get it to work within the conditional actions.

Thanks for your help anyway!