Create Record Automation Only Adding Partial Words!

Help please!

I created a ‘Create Record’ automation with the following trigger:

When a record matches conditions in table 1, it creates a record in table 4. (Works Fine)

The problem is with the record it CREATES in table 4. It’s doing exactly what I want when it runs the test, but when I create a NEW record in table 1 that matches the conditions (triggering the action of creating the record in table 4), it’s filling in the field in table 4 with ONLY the first letter of the word(s) it’s supposed to be inserting. I cannot figure out what I’m doing wrong :weary: Any help is so appreciated!!!

Here’s a guess: part of your condition to trigger the automation is that a given field in table 1 isn’t empty. Is that correct? If so, that explains the issue. The moment you type a single character in the triggering field, it’s no longer empty, and the automation triggers at that exact moment, receiving the triggering record data as it exists in that moment. Airtable doesn’t care that you’re still typing. That one character was enough to trigger the automation, and that one character is all that gets passed through.

To fix this, you need to effectively manufacture a delay in the trigger. Create a formula field named something like {Automation Trigger} (or whatever you prefer), with this as the formula (assuming that some field must not be empty to trigger the automation):

AND({Field Name}, DATETIME_DIFF(NOW(), LAST_MODIFIED_TIME({Field Name}), "minutes") > 1)

Replace both instances of {Field Name} with the field that currently drives your automation condition. That formula will output a 1 only when {Field Name} is not empty, and the last time that it was updated was over a minute ago. (Note: NOW() only refreshes every few minutes, so the actual delay will likely be much longer than just a minute, but that’s the best that can be done for now.)

Now change your automation to trigger using the condition that this {Automation Trigger} field = 1. When the record is first created, it will output a 0, and will only switch to 1 once when those conditions are met, so the automation will only trigger once after you’ve had plenty of time to populate that field with whatever you need.

1 Like

@Justin_Barrett’s idea is great! Note that Airtable only updates NOW() every 5-10 minutes or so if your base is open, so the delay might be up to 5-10 minutes.

Alternatively, you can just create a checkbox field to trigger the automation when you check the checkbox.

1 Like

Thank you!!! That’s exactly what the problem was because, yes, one of the conditions was that the field was NOT empty. It works perfectly now :slight_smile:

Thank you!! That’s a really good idea too. I’m going to utilize that in other parts of my base where it will work perfectly!!! :slight_smile:

Glad to know that you got the answer you were seeking! If you would, please mark my comment (the one above, not this one) as the solution to your question. This helps others who may be searching with similar questions. Thanks!

ciao
io ho un altro problema.
ho creato 2 tabelle calendario; vorrei che ogni volta che nella tabella 1 viene creato un record, questo venga duplicato nella tabella 2.

ho creato l’automazione, ma nella tabella 2 mi crea un record vuoto. io ho bisogno di tutti i campi: nome, data, ora etc.

qualcuno mi aiuta?

grazie

Benvenuto nella comunità, @Stefano_Florian! :smiley: Quando si costruisce una struttura dati, non è consigliabile duplicare gli stessi dati in più di una posizione. Se devi mostrare lo stesso record in gruppi diversi (filtrati, ordinati, ecc.), ti consiglio di guardare le visualizzazioni. Ecco dove puoi leggere di più su questa funzione:

Su un lato nota, se la tua domanda non è esattamente la stessa di quella che ha avuto inizio un filo, è meglio iniziare un nuovo thread, invece di aggiungere ad uno che è su un tema diverso.

(Colpa Google Translate se il mio italiano è meno che perfetto :slight_smile: )

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.