Created date time field has wrong timezone


#1

I’m using Zapier to create a new record in one of my bases. The Zapier web hook is sending a date and time that looks like “2017/05/12 7:07:51 PM”. I have a datetime field in my base that receives that data, but it gets converted as though the incoming datetime is in the GMT timezone. My Zapier task history shows that record created in Airtable has “2017-05-12T19:07:51.000Z” in that field.

I tried pasting “2017/05/12 7:07:51 PM” directly into the field in my base, and Airtable uses my local timezone instead of thinking it’s GMT.

Is this a bug? See below for screenshots from my Zapier task history.



#2

When you do this in the UI, we know your browser time zone. We can then interpret 5pm as 5pm in your current time zone.

When you use Zapier or public API, we don’t have that information, so we assume that the time is in UTC.

One option is to shift the time using Zapier if you know the timezone of your incoming dates.

You can use “use the same timezone for all collaborators” and that will kinda solve this, but the time won’t change depending on where you are. So London and LA will see 5pm, which may be confusing.

At some point we will have an option to pick the default timezone for a base. I don’t have an ETA for that. However there will still be cases when the incoming date is not the same timezone and you’d still need to do something in Zapier to figure out what’s the right timezone.


#3

Thanks for the info, Alexander. I see the difference now. If I specify the timezone in the timestamp that I’m sending to Airtable, would it do the right thing? I don’t think so based on my tests, but that might make sense as a way forward.

It does work to append an offset, for example, “2017/05/15 7:07:51 PM -05:00” looks like it will work. I think I can append the offset corresponding to my timezone to the data in my HTTP POST. That might do the trick.