Download CVS of view does not Gove that view

#1

I am trying to download a particular view to CVS using the ellipse icon on the view menu bar. The view has 2 groupings, 2 filters and 6 hidden fields. When I click the download button, I only get the data from the main grid created when the table was created. It does not include the group fields. I have tried this with 2 different views that include groupings with the same result. I do get the sorts.

Does anyone have any thoughts on what is happening. The help files indicate that this should not be the case. But they are not very detailed. Just, click the ellipse and all will be well. Hmmm.

Thanks, Scott

0 Likes

#2

Hi Scott, what do you mean by ‘group’ field?

The expected behavior is that the .csv file will only have data for those fields that were visible in the view when the file is downloaded.

0 Likes

#3

The view is grouped on a field. That field is missing from the cvs file.

Scott Brasted - Brasted House Creative Ideas
work@brastedhouse.com

0 Likes

#4

can you post a screen shot of the View you are exporting and the resulting headers in the .csv?

0 Likes

#5

Hi Mike,

Here are screen shots of the view in Airtable and the resulting Excel worksheet that was downloaded by Airtable. As you can see, the Season and Composer fields are missing from the CVS file. It starts with the Title. When I read the help page, it indicated that Airtable would download the view’s information. It does not indicate that there is any trouble with groupings in the download. IS there something I am missing ?

Many thanks for your help.

Best, Scott

work@brastedhouse.com

0 Likes

#6

I’m not seeing the problem(?) all of the displayed fields in the view are exporting.

If you want the other ‘grouped-by’ field to export, you’ll have to un-hide it.

0 Likes

#7

Are you saying that the fields used to group also need to be exposed in the grid? If so, it seems counterintuitive, since they are visible in the group already. Then that means they will be in the export twice and I will have to manually remove them in Excel. While not a big deal, it is ironic that the machine that is supposed to be doing the heavy lifting is not doing the heavy lifting.

We call this “computer as typewriter” syndrome.

Best, Scott

work@brastedhouse.com

Brasted House Creative Ideas

0 Likes

#8

I’m very confused as to what data you want to be exported.

What I see are 9 Fields in the View in airtable.
I also see the same 9 columns in .csv file you exported.

Is the issue that the Records are not in the same order as they are displayed in the .csv?

Or do you want the Records that have been filtered out to be exported?

0 Likes

#9

I think have a case of apples not being oranges, here: A database is not a spreadsheet.

When you perform a CSV export, you are exporting individual records from the database; the view used is important only in determining which fields are to be exported; those hidden in the view will not be included in the export. The display mechanics of the view are irrelevant: As there is no individual record corresponding to the name of a composer and a count of his or her works, such a record could not be included in the export.

Try this: Display, say, a gallery view of your base. Now click the ‘maximize’ tab on your browser window so the view shows fewer columns, but more rows, of cards. Would you expect the CSV export to change accordingly? Or, for that matter, collapse the 'Christmas, Easter, Lent' group: What Messiah-related records would you expect to see the export contain?

If you’re trying to maintain record order when moving to Excel, you can try copy-and-pasting the values rather than exporting them. To do so

  1. Sort your records according to your groupings. That is, in your case you would sort by {Season}, then by {Composer}, and finally by {Title}.
  2. Choose a view that includes {Season}, {Composer}, and {Title} as unhidden fields.
  3. Check the checkbox in the header row of the table — that is, the one next to the field names.
  4. Press Ctrl-C to copy all checked records. (Note that in the case of a grouped view, checking the header-row checkbox selects all records that would be visible in that view with all groups and subgroups open; collapsing a heading does not remove those records from being selected.)
  5. Go to cell A:1 in an Excel sheet. Press Ctrl-V to paste the copied records.

This should maintain the sort order, including the [implicit] groupings; CSV exports, in contrast, appear to maintain the order in which records were added to the base. If you need subheads in Excel, you’ll have to add them manually.¹


  1. ‘Manually’ in this case also meaning ‘by means of an incredibly clever and slick Excel macro that I am not about to try to hack together.’
0 Likes