Help

AirTable Automations Are Breaking My Links

Topic Labels: Automations
Solved
Jump to Solution
6877 20
cancel
Showing results for 
Search instead for 
Did you mean: 
xavier_williams
5 - Automation Enthusiast
5 - Automation Enthusiast

I have built an automation that fires off an email to a key stake holder with information found in different fields.
One of these fields contains a link. When the automation fires, the email is sent along with a slack notification.

The slack notifaction contains the same information the email should, BUT the link in the email is altered by the automation and the link in the slack message seemingly works.

The automation is grabbing the same URL from the same field. I am not sure why the URL is changes in the email but not the slack message.

To add additional information, the email is removing the under-scores from the URL and the Slack message is not.

Can anyone help?

20 Replies 20

I figured it out for URLs produced with formulas!

You’re right, when the URL is hardcoded into the email, escaping the backspaces works fine, but for some reason, URLs produced by a formula and then inserted into the email dynamically always break.

I realized that no matter what you do, the underscore has to be hardcoded into the email.

So I used formulas that break up the URL into the sections around the underscores, and then put it all together in the email.

[dynamic inserted url portion]_[dynamic inserted url portion2]

So you have to create several fields, one for each portion of the url broken by an underscore, and then put those fields into the email around a hardcoded “_”.

It’s annoying, but it totally solves the problem.