Help

Re: Attachments in Send Email Automation not Working anymore

Solved
Jump to Solution
2844 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Paul_Falcon
4 - Data Explorer
4 - Data Explorer

Edit:

Airtable response: 

Our engineering team has successfully deployed a fix for this issue (which arose from a recent update to our code) and any automations referencing an attachment should now run as expected without error.

It's working again. Thank you all.

---

Hello.

I've been using the Send Email action in automations for more than a year. Always worked great. In the Send Email action, in the Attachments section (Bottom) I selected the column that contained the file, and that file was attached in the email.

Captura de pantalla 2023-04-24 a la(s) 1.49.20 p.m..jpg

3 days ago, my automation worked fine. But today, when the automation triggered, there was a problem (An attachment url is disallowed):

Captura de pantalla 2023-04-24 a la(s) 1.53.48 p.m..jpg

I already turned off and on the automation, changed the trigger, changed pdf file for jpg, and always the same error.

I tried the automation with records that already triggered a few days ago and worked fine (My trigger is a Single select column, so, to trigger it again, I deleted the value in the single select field, and select it again). Same problem.

I already wrote to Airtable Support, but I wanted to write here too, because it is a very important feature in my workflow, and maybe one of you can help me find a solution or a workaround.

Thank you very much for your help.

36 Replies 36
mark_winter
4 - Data Explorer
4 - Data Explorer

This is still an issue with us, and the automations are CRITICAL to our business operations, as they are tied to reporting requirements for our clients.

I need this fixed yesterday - absolutely ridiculous that this is still an issue. This is basic functionality.

Does anyone have any suggestions?

Moni_Singh
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi ,

All out automations have stalled due to this issue. It started today . Has anyone else had issues since this update?

 

Illan_ZEMMOUR
5 - Automation Enthusiast
5 - Automation Enthusiast

Same problem

Support cannot be reached by email as email support has been deprecated for "plus plan" users...

And their chat is powered by a bot... I can't even find how to submit a ticket....

This is not acceptable for paid users to have such a bad / non existent support

Eric_McFetridge
6 - Interface Innovator
6 - Interface Innovator

This error has now started to affect our important automations (again). I have reached out to enterprise support and will update here when I hear back.

I have excatly the same problem, today June 29th

The problem is not solve. It is impossible to send an automation with send an email with attchment made from a form

Eric_McFetridge
6 - Interface Innovator
6 - Interface Innovator

Here is the response from enterprise support with a workaround for this behavior. I am not sure why this issue has popped up after months of it not being a problem.

Based on the error message you're seeing, it's likely the automation is firing before the attachment has been fully imported into our storage. Once a file has been fully uploaded into our storage, the attachment will then feature its unique Airtable URL instead.

We're working on improvements to this behavior, but in the meantime, there are a couple of ways to delay the automation (depending on your particular use case) to give the attachment time to fully process would be:

  • If you're using a singular attachment field, and the field will contain one or more attachment(s) within the field, you can create a formula field in the table where your attachment field lives and use the following formula which will output "RUN": 

IF((LEN(Attachments)-LEN(SUBSTITUTE(Attachments,",",""))+1)*15=(LEN(Attachments)-LEN(SUBSTITUTE(Attachments,"dl.airtable.com",""))),"RUN")

From here, you'll add conditions to your trigger step saying "When Attachment formula contains 'RUN' " (like this)

  • If you need an email to be sent even if there is no attachment present, you could use the following formula to output "NO ATTACHMENT" when there is no attachment and "RUN" when there is. The automation condition would be "When Attachment formula is not empty" (like this😞

IF(NOT(Attachments), "NO ATTACHMENT", IF((LEN(Attachments)-LEN(SUBSTITUTE(Attachments,",",""))+1)*15=(LEN(Attachments)-LEN(SUBSTITUTE(Attachments,"dl.airtable.com",""))),"RUN"))

Now, the automation should wait until the attachment is processed before being triggered.

that is super complicate, do you have a simple solution?

Eric_McFetridge
6 - Interface Innovator
6 - Interface Innovator

Here is another solution I can think of that would be simpler.

Create a formula field called "Send Email" with this formula:

IF(CREATED_TIME()<(DATEADD(NOW(),-20,"seconds")),"Yes","No")

Change your automation trigger from 'when a form is submitted' to 'when a record matches conditions'.

Make the trigger condition 'when Send Email contains Yes'.

Although this would appear to delay the automation by 20 seconds, in reality it will delay the automation by up to 5 minutes, since "NOW()" in Airtable only updates every 5 min or so. If the email going out 5 minutes later is better than the automation failing, this may work for you.

Erica_Bass
4 - Data Explorer
4 - Data Explorer

Same issue on many business critical automations 😭