Help

Automation - Copy fields : limited number of fields you can copy from

Topic Labels: Automations
1956 13
cancel
Showing results for 
Search instead for 
Did you mean: 
Jose_Mendez
5 - Automation Enthusiast
5 - Automation Enthusiast

Trying to copy one field to another in the same table as stated in this article Update record Action – Airtable - Support

I got a Received invalid inputs error message

13 Replies 13
Jose_Mendez
5 - Automation Enthusiast
5 - Automation Enthusiast

I managed to correct the error, but I found another one.
I noticed that just a limited number of fields (just 😎 are available to copy from.

  1. Is this a rigid limit?
  2. If yes, it is possible to select these fields?

Welcome to the community, @Jose_Mendez! :grinning_face_with_big_eyes: The limit you’re seeing isn’t based on a specific number of fields. Chances are you have some fields that Airtable doesn’t currently provide access to via the automations system. Could you describe your setup in greater detail, including the field types of the fields you want to use in the automation?

Jose_Mendez
5 - Automation Enthusiast
5 - Automation Enthusiast

Thanks @Justin_Barrett for your reply. I am new with Airtable and I found a better way to get what I want that is to replace some values inside an URL. I used the text formula for it.

Hi Jose, am also new to Airtable and am trying to get my bases to update when a new record is entered in a Google sheet. However, the automation requires each of the fields to be specified - and I have a very large number. So, how exactly did you get your automation to work.

Also though the notification says test ran successfully, I can’t see any corresponding updated values.

Jose_Mendez
5 - Automation Enthusiast
5 - Automation Enthusiast

I used Google Sheet before but I moved my database to Airtable, so I am not doing what you are looking for. Did you try to import Google Sheet into Airtable?

Yes. I’m trying to get data from Google sheets to Airtable. Managed to get the automation working. But there doesn’t seem to be a way to automatically update all fields in a row.

Also, though the automation runs and gives results on testing, when I select Google sheets in the trigger part, I get a notification saying that the spreadsheets aren’t supported.

Also, how does one run an automation manually? Does it happen when you switch it on? Tried that and nothing seems to happen. The only way to get it to happen seems to be by testing again.

Welcome to the community, @Atul_Londhe! :grinning_face_with_big_eyes:

An automation runs based on a trigger. Turning an automation on just tells Airable to begin watching for that trigger. Automations can only be run when that trigger activates. In the case of Google Sheets, the trigger is the creation of a new row in a spreadsheet. Once that happens, all data in that row is available in later steps in the automation.

The timing of the trigger is important to know. As the name implies, the Google Sheets trigger fires when a row is created, and the data sent to Airtable is the data in that row at the moment of its creation. If the row is created, and then data is added to various cells in that row after its creation, those cells’ contents won’t get passed to Airtable. The same thing goes for new records created in Airtable. If an automation trigger is “When record created”, the only data sent to the automation is data available at the time of the record’s creation.

Can you be more specific re: the error message? You can take a screenshot and drop that into a reply, which will provided the clearest picture (literally) of the problem.

Hi Justin,

Thanks for a very clear and informative reply and for taking time out on New Year’s Eve to do it.

The reason I asked about triggering the automation manually (contradiction in terms!) is that I’m on the free plan and I had misread the plan details which actually said that syncing tables was manual on the free plan but I had initially thought that that it was talking about automations. So, that was confusion on my part.

As regards the ‘error message’ I’m pasting a screenshot below to provide a ‘clear picture’ : ) as you had suggested:

Airtable - Google Sheets not Supported Error

The message is in the red rectangle.

Just to provide a bit of context, what I’m trying to do is import a row from a Google sheet which has over a hundred columns into Airtable. I was trying to figure out a way of automating the importation of the whole row at one shot i.e. without having to specify each field in Airtable and what needs to go in each field. What I’m really interested in is finding out if there is some way of doing this.

When I tried to do this using a Zap instead, there were problems which I am currently looking into and which may be related to the error I’m getting in Airtable.

It would be great if you could let me know how to update a whole row without having to specify the details since with over a hundred fields, it becomes very tedious and leaves lots of room for error.

Thanks again for your prompt and helpful reply.