Help

Re: Automation- email to a group based on a Airtable field.

Solved
Jump to Solution
1271 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Wendy_Yelsik
6 - Interface Innovator
6 - Interface Innovator

Hello. 

I am setting up automation and need to program "To" to grab the emails from a field in my airtable base.  For example, when I need to send a report to just the operations department, I want to assign that report to that email group.   I use Outlook Email for the automation.   Here are some screenshots.   I can't get the automation to recognize a field I enter with the email addresses.      I tried a field using the addresses as one line separated by a comma and then tried three fields with a different email address in each.  Neither worked. 

What am I doing wrong or is there a better way to handle this? The PDF is generated by PDF Generator API if that makes a difference.  

Thanks. Wendy

1 Solution

Accepted Solutions
Stephen_Orr1
10 - Mercury
10 - Mercury

Could the selected record associated with the button click or automation test not have email values populated?

The "When a button is clicked" automation trigger requires the button to be placed on an interface page that contains either a Record Picker or Record List element more info . This is so that a single record can be selected to feed data (such as email field values) to subsequent automation actions.

To rule out whether it's the automation setup vs. missing data in the trigger record, you could try to create the same automation (send an email with dynamic field values in the "To" settings) but with a different trigger. If this works, I would take a closer look at the interface page containing the button and ensure the email fields in the selected record are indeed populated.

Hope that helps!
-Stephen

See Solution in Thread

3 Replies 3

Hi @Wendy_Yelsik,

What is the error you see when generating a preview? This is working for me.

Hi, @Stephen_Orr1 .  I get this error - The "To" input is empty

Wendy

Stephen_Orr1
10 - Mercury
10 - Mercury

Could the selected record associated with the button click or automation test not have email values populated?

The "When a button is clicked" automation trigger requires the button to be placed on an interface page that contains either a Record Picker or Record List element more info . This is so that a single record can be selected to feed data (such as email field values) to subsequent automation actions.

To rule out whether it's the automation setup vs. missing data in the trigger record, you could try to create the same automation (send an email with dynamic field values in the "To" settings) but with a different trigger. If this works, I would take a closer look at the interface page containing the button and ensure the email fields in the selected record are indeed populated.

Hope that helps!
-Stephen