Automation error: "An attachment url is disallowed" when run automatically

Topic Labels: Automations
5740 11
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Hello everybody,

I have a weird problem with a gmail automation. When testing the automation works perfectly. The automation looks for a field value that is greater than 4 and then the actions are run.
2020-12-18 om 15.41.30

When manually changing the a value in the record that is used for the automation to a value greater than 4 the automation also runs perfectly.

But when the automation its run automatically I suddenly get the following error in the logs:
2020-12-18 om 15.39.49

It doesn’t make any sense that this automation suddenly throws errors when it is run automatically, but every other way of running it works fine. Also, when this same automation is run again manually it just works…

Someone any idea what’s going on?

2020-12-18 om 15.55.57

11 Replies 11
4 - Data Explorer
4 - Data Explorer

Hi Thimo,

I had exactly the same problem. In my case I think it was down to the automation attempting to send the email before the previous step had completed the upload of the attachment that took place in a script that I was running. To resolve the issue I created a new job to run after the previous one had finished, and a small time had elapsed to allow all of the file uploads to complete, that then changed the status to kick off the email send instead. This looks like it has fixed the problem.

Hope this helps.



Hi Chris, thank you for your message!

This may also be the case for me, but I couldn’t find a solution for it back then. I ended up using the Airtable triggers in Zapier to recreate this automation and that worked perfectly! Also good to hear that you found another solution :slightly_smiling_face:

4 - Data Explorer
4 - Data Explorer

I think I found a great solution for this issue. At least it works great with a single attachment.

In my case I’m triggering an automation based on a record entering a “To send” view. Whenever it triggered automatically I got an error in the Gmail action step since the attachment had not finished uploading by the time the automation triggered.

Here’s what I did to fix it:

  1. Created a Formula column that just printed the attachment column. Assume your attachment column is named “CV or resume” the formula would simply be {CV or resume}.
  2. This column will print the name of the file as well as a URL to the file. The great thing is that the URL changes once the file has completed the upload. It goes from something like cv-2021.pdf ( to cv-2021.pdf ( So just add a filter for the formula column containing and you should be good to go.

See example video: Airtable PDF upload example...

Of course, this approach probably won’t work if the field has more than one attachment, as the first attachment is likely already uploaded. You could add another condition to exclude, however I’m not sure if that domain is always the same. I believe I’ve also spotted something starting with api. or something similar, but I can’t reproduce at the moment.

4 - Data Explorer
4 - Data Explorer

The way I solved is, I created views for the conditions. And added Automations on those views. Once the data gets inside a view based on some conditions ( used “When record enters view”). Directly applying conditions on an automation had the mentioned problem.

5 - Automation Enthusiast
5 - Automation Enthusiast

THIS. WORKED. PERFECTLY!!!! Omg, I was trying every which way to get Airtable to slow down its automations to allow Documint to complete generating a contract. I literally spent an entire work day and all weekend trying to outsmart Airtable. Then I tried this and it worked exactly as I needed.  

Please note, Airtable Gods: Create a "wait" option in your automations so we don't have to figure out how to kludge together a solution. 

Thank you!!!

Hi , I thought your solution would solve it ... but no, still fails..  Good idea though!

Airtable team ... please enable a "wait until completed" instruction

Thanks! it works fine now.

This seems to be the only solution.   Have you tested the exclusion criteria in case of multiple attachments?

4 - Data Explorer
4 - Data Explorer

This is still an issue for me on multiple automations. I've tried duplicating the automations and it doesn't fix it. When I run a test automation, it works. It's only when it tries to actually run that I get the error. Please fix this!

5 - Automation Enthusiast
5 - Automation Enthusiast

I attempted a fix using Thomas_K_Runnin's idea but to handle multiple attachments. It seems overly cumbersome but so far seems to be working. Welcome all feedback to make this less clunky.

  1. I have a formula field counting the instances of "" (which should equal the total # of attachments). 
  2. I have 2nd formula counting the actual number of attachments from my attachments field. 
  3. I have a 3rd verification formula subtracting the results of the two formulas above (should = 0 once uploading complete)
  4. I have an automation set to update a status field to "uploading" with a trigger of When Record is Created 
  5. I have a filtered view (locked) set to only show records with status = uploading AND verification formula = 0. 
  6. Lastly, a 2nd automation to actually send the email When Record Enters View (referencing view above).