Re: Automations Failing

Jump to Solution
5124 3
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Hey everyone!

Today we had an issue where a few of our automations started failing due to all of our “Link to _” fields breaking. We have been using these fields as a main link between tables, and they have all started failing with the same error:

Field “_ ID” cannot accept the provided value: Cannot modify a computed field.

Does anybody have any idea what might have happened? This all started happening around 1:30pm EDT today, and it is not just one table, but at least 4 or 5 tables. Any insight into what might have happened would be very much appreciated. It is a very big workflow issue for our company as this drives a lot of what we work on a daily basis. Thank you!

1 Solution

Accepted Solutions

In the meantime, you can try changing the automation so that the “Create record” action for [Table B] will use the record ID of the triggering record in [Table A] in the {table A ID} field.

See Solution in Thread

23 Replies 23

Welcome to the Airtable community!

Have there been any changes to the base schema? Have the field types for any fields changed?

If there have been no changes to any field types or field configurations, I recommend contacting Airtable support.

There have been no changes. We have a base with 5 users and I am asking around as to whether any of them were on at that time, but I have specifically tried to add permissions to the tables so that I am the only one who is able to edit, and I was not online today.

I have contacted Airtable support, but I have not heard a response.


When you changed the permissions, did you set the field so that automations could also edit the field as well? If not, that may be why the automations are failing.

Yep, I have allowed automations to run it. I added these permissions months ago, and it only started failing today!

5 - Automation Enthusiast
5 - Automation Enthusiast

So to recap what I have found so far -

  • We had an automation break between 1:27pm and 1:40pm EDT on August 2, 2021.
  • None of our users were on Airtable in this time frame. None of our users except myself (who was not online) are able to edit the fields in question
  • The automation is failing with a message of: “Field “_ ID” cannot accept the provided value: Cannot modify a computed field.”
  • Changing the table field to match what it was before does not work. Changing the field to “Single line text” does make the automation work, but it does not allow our workflow to be functional.
  • Creating a base snapshot from yesterday (August 1 2021 at 5:39pm UTC) still does not fix the automation. At this time the automations were running properly.
  • This has happened to multiple tables at seemingly the same time. No way to test this as they were in the same automation and the first one failed. When I made the first one a “Single line text”, the second one failed with the same error. They have a similar structure but are different tables.

What was the field type before? Was the field a formula field?

What is the value that automation is trying to put in the linked record field? Does that value already exist as the primary field value for exactly one record in the linked table? If the value does not exist, and the primary field is a formula field, I would expect the automation to fail. If the value does not exist, but the primary field is a single line text field, Airtable would create a new record with the given value in the primary field.

It was a “Link to Record” field. It is how multiple tables of ours communicate data to one another. It was trying to put in an “ID”, which was created as an autonumber on a separate table.

If the number did not yet exist in the primary field of the linked table that is your problem. Check how those numbers are generated and make sure that when trying to link to a record, that the target record will already exist.

The new entry is set on a trigger when the table with the primary row is created.

To explain the automation:
Once an entry in table A is created, create an entry in table B with “table A ID” set to the primary key (autonumber) of table A.

The error we are getting is:
Field “table A ID” cannot accept the provided value: Cannot modify a computed field.