Re: Automations Failing

Jump to Solution
4282 1
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Hey everyone!

Today we had an issue where a few of our automations started failing due to all of our “Link to _” fields breaking. We have been using these fields as a main link between tables, and they have all started failing with the same error:

Field “_ ID” cannot accept the provided value: Cannot modify a computed field.

Does anybody have any idea what might have happened? This all started happening around 1:30pm EDT today, and it is not just one table, but at least 4 or 5 tables. Any insight into what might have happened would be very much appreciated. It is a very big workflow issue for our company as this drives a lot of what we work on a daily basis. Thank you!

1 Solution

Accepted Solutions

In the meantime, you can try changing the automation so that the “Create record” action for [Table B] will use the record ID of the triggering record in [Table A] in the {table A ID} field.

See Solution in Thread

23 Replies 23

Welcome to the Airtable community!

Have there been any changes to the base schema? Have the field types for any fields changed?

If there have been no changes to any field types or field configurations, I recommend contacting Airtable support.

There have been no changes. We have a base with 5 users and I am asking around as to whether any of them were on at that time, but I have specifically tried to add permissions to the tables so that I am the only one who is able to edit, and I was not online today.

I have contacted Airtable support, but I have not heard a response.


When you changed the permissions, did you set the field so that automations could also edit the field as well? If not, that may be why the automations are failing.

Yep, I have allowed automations to run it. I added these permissions months ago, and it only started failing today!

5 - Automation Enthusiast
5 - Automation Enthusiast

So to recap what I have found so far -

  • We had an automation break between 1:27pm and 1:40pm EDT on August 2, 2021.
  • None of our users were on Airtable in this time frame. None of our users except myself (who was not online) are able to edit the fields in question
  • The automation is failing with a message of: “Field “_ ID” cannot accept the provided value: Cannot modify a computed field.”
  • Changing the table field to match what it was before does not work. Changing the field to “Single line text” does make the automation work, but it does not allow our workflow to be functional.
  • Creating a base snapshot from yesterday (August 1 2021 at 5:39pm UTC) still does not fix the automation. At this time the automations were running properly.
  • This has happened to multiple tables at seemingly the same time. No way to test this as they were in the same automation and the first one failed. When I made the first one a “Single line text”, the second one failed with the same error. They have a similar structure but are different tables.

What was the field type before? Was the field a formula field?

What is the value that automation is trying to put in the linked record field? Does that value already exist as the primary field value for exactly one record in the linked table? If the value does not exist, and the primary field is a formula field, I would expect the automation to fail. If the value does not exist, but the primary field is a single line text field, Airtable would create a new record with the given value in the primary field.

It was a “Link to Record” field. It is how multiple tables of ours communicate data to one another. It was trying to put in an “ID”, which was created as an autonumber on a separate table.

If the number did not yet exist in the primary field of the linked table that is your problem. Check how those numbers are generated and make sure that when trying to link to a record, that the target record will already exist.

The new entry is set on a trigger when the table with the primary row is created.

To explain the automation:
Once an entry in table A is created, create an entry in table B with “table A ID” set to the primary key (autonumber) of table A.

The error we are getting is:
Field “table A ID” cannot accept the provided value: Cannot modify a computed field.

Hey @kuovonne , I’m the product lead on this project.

The problem is that this automation was working, 100% correctly, for 3+ months. So all of your debugging questions, which we appreciate, will be answered in the negative. The automation worked according to spec for several months.

Specifically in response to your suggestion for debugging - the value already exists as value for one record only in linked table. That’s how the automation was able to work flawlessly for several months.

At the time of failure, no user was logged into Airtable and using the system. No new automations or changes were made. No limitations under our Pro Plan were reached. No erroneous record was introduced.

Yet this core automation broke, and our business can not function without it.

In order to debug, Jack, as he mentioned, changed the type of field from ‘Link to [table]’ to ‘single line text’, and this causes the automation to work. But then we can no longer do necessary operations in our workflow - we need to have the field remain a ‘Link to [table]’. So switching permanently to ‘single line text’ is not an option.

So the question is: what could possible cause a long-running automation to suddenly fail at a time when no users were logged into Airtable, no changes were made, and no limits were exceeded?

This is urgent as our business can not run.

I’m sorry, but I do not know what could cause a long-running automation to suddenly fail as described in this thread. As I suggested in my first post, I recommend you contact Airtable customer support.

This is a community forum where that vast majority of users are other Airtable customers (myself included). Airtable support will have access to inside information, such as whether or not Airtable changed anything behind the scenes (which it occasionally does without announcement).

When you contact Airtable support, you can include the URL for the automation in question. This support article describes the information that Airtable recommends including in your support request.

In the meantime, you can try changing the automation so that the “Create record” action for [Table B] will use the record ID of the triggering record in [Table A] in the {table A ID} field.

This seemingly fixed it!

Using the Airtable Record ID is working. We were originally using the autonumber type primary key in the “Link to record” fieldm, but now using the Airtable Record ID is working, and showing the primary key in the field. I believe in the past it would have shown the Record ID itself, the long string starting with rec____, but it doesn’t seem to be anymore.

Thank you @kuovonne so much for the help! You are amazing!

I will keep in contact with the Airtable support to see whether they have changed something in how the automations work. This is a pretty big breaking change to our automations and I am surprised if we are the only case of it happening.

I’m having the same issue (my automation was previously working, then this problem occurred) but I can’t use this solution.

I currently have an automation that pulls in data from a google form, which then creates a new record in Table B. One column is the Primary key to Table A (i.e., one of the google form inputs is the primary key) , which was how I was linking Table B to Table A.

I’m doing something similar in another table to the same effect - now broken after having worked for months. Any possible fix here or update from Airtable Support?

I recommend that you contact Airtable support directly.

Can you explain why you cannot use the record ID in the automation? Note that I am not saying to change the primary field in the [Table A]. I am suggesting that you change which value you select in the automation configuration.

So my automation flow is:

Trigger: Google sheets row is created

Actions: Create record (in Table B); the record fields are (all pulled from the new google sheets row):

  • Applicant ID (the primary key for Table A, and how I’m linking Table B to Table A)
  • Name
  • Etc.

The current error is ‘Field “Applicant ID” cannot accept the provided value: Cannot modify a computed field’

I’m not sure where I would use record ID here, could you clarify?

Can you include screen captures of your data and your automation configuration?

Intro call table, which is linking to the Enrollment data table:
Enrollment data table:

Thank you for the screen captures. It looks like your trigger is a new record in Google Sheets, not a new record in Airtable, so you do not have a record ID of a triggering record.

This scenario is a bit more complex than I can volunteer to troubleshoot over the forum right now. Hopefully Airtable support can give you some feedback on why the automations are no longer converting field data properly any more. It may be in part because the value is a number and not a string.