Help

Re: bug after the recent update - email automation with attachment

1819 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Firuza_Davletsh
4 - Data Explorer
4 - Data Explorer

There must be a bug in the recent update. Last week I noticed a change in the interface when I attach files. Since then every single email automation with attachments fails to run due to "attachment url disallowed". Everything worked fine for the past few years, no changes have been made to automation. Therefore, they messed up something in the recent update. The automation test runs fine with no errors. So, nothing wrong on my side. Airtable support chat bot offered to clear the cache to solve the issue, which I did. It seemed to work temporarily. However, I have to clear cache each time for the automation to run, which is unacceptable. Also, clearing the cache is not helpful when the email automation with attachments runs from the forms (i.e. someone submits the form and uploads an attachment, which triggers the email automation). It worked perfectly fine for many years. It looks like there have been multiple reports of this issue in the Airtable community forum, but the issue remains unsolved.

11 Replies 11
Sho
11 - Venus
11 - Venus

It appears that Automation no longer allows you to create email attachments directly from a form.
It is required to write the form to the record and then send the email as an attachment from the record.

Solved: Attachments in automation-generated emails causing... - Airtable Community

My automation is designed to run when the record is created (regardless of whether manually or from the form). So, this does not apply to my situation.

correction: my automation is designed to run when the record matches conditions - when the attachment field is not empty. So, it shouldn't really matter whether the record is created/updated directly in the airtable base or submitted through the form. Also, it worked for two years with no issues.

Sho
11 - Venus
11 - Venus

I was hoping if it could be improved...

The email function seems to have a critical problem.
That's a serious problem if you're using it for business use.
We are waiting for Airtable to support this issue.

Aaron_Smith
5 - Automation Enthusiast
5 - Automation Enthusiast

This is horribly disruptive for my business.  I am on the Enterprise plan.  I need some help here.  My business relies on this system for communication, and now it just fails without warning.  

Report it as a bug to support@airtable.com, and let us know what they say.

Firuza_Davletsh
4 - Data Explorer
4 - Data Explorer

I found a workaround. I added one more step "find records" before the action "send email".

Firuza_Davletsh_0-1688153876099.png

Then flatten attachment.

Firuza_Davletsh_1-1688153914642.png

However, this works only for one attachment. For the email automation with two attachments, only one file attaches to the email although test run works fine. So, the issue is not completely resolved. Still waiting for the technical support to get back to me. 

 

Thank you for helping, but as a paying user I expect Airtable to fix THEIR bug.  I have countless automations that are affected, and have no idea they are impacted until they fail.  This needs to be fixed by Airtable.  

Aaron_Smith
5 - Automation Enthusiast
5 - Automation Enthusiast

I also found a solutions that seems to work, but still think they need to fix it.  I added a formula for "Minutes since creation" 

DATETIME_DIFF(NOW(),Created,'minutes')
I then filter my view to trigger the automation 8 minutes after creation.  I tried 5, but still had some issues.  8 seems to work, but again they need to fix this bug.  I don't have time to fix their mistakes.