Upcoming database upgrades. Airtable functionality will be reduced for ~15 minutes at 06:00 UTC on Feb. 4 / 10:00 pm PT on Feb. 3. Learn more here

Fields could not be converted to a string

Topic Labels: Automations
675 5
Showing results for 
Search instead for 
Did you mean: 

Hi all, I have run into a problem with an automation where I am copying values from some formula fields into fixed fields. I have narrowed the problem down to 2 different fields that halt the automation. Both the formula field and the fixed field I am copying to are formated as decimal with 2 places (x.00). I know this worked before while I was developing it, but now it fails. The error message shown is “fields could not be converted to a string”. I see 2 questions for this topic in the Community, but I can’t see the solution. This is making my head explode, so I would appreciate any help you can provide.

5 Replies 5

Would you be able to share a screenshot or two of your automation setup and the related fields?

Hi @Justin_Barrett, thanks for responding (and sorry it took me so long to get back to you). I figured out the issue I think, and it was an error on my part.

Can you tell us what the solution was @Sharon_Visser ? I have a similar problem

Hi @Julian_E_Post, ugh, once I realized I had made a mistake and corrected it, I didn’t document the issue. My recollection is that I had meant to copy the formula into 2 fixed fields, but I think I was actually trying to copy to a formula which you can’t do because well, it’s a formula. I wish I had noted the issue and added it to this thread at the time.

All good, thanks for trying to remember. I think I solved my problem by using the new conditional logic in my automation to run the calculation only when the field is not empty. It hasn’t failed yet, so maybe it threw that error when trying to multiply against an empty field?