Help

Formatting in Slack Messages

Topic Labels: Automations
6742 18
cancel
Showing results for 
Search instead for 
Did you mean: 
egordin
7 - App Architect
7 - App Architect

I saw elsewhere that Airtable-limited markdown is available for Automations (possibly only for emails? - not clear), but I can’t seem to get the markdown to work for Slack message automations.

:loudspeaker: : The Accounting base in :airtable: has been updated by
[Record (Step 1: Trigger) | Field values | By | Name] with the following release notes:
‏‎[Record (Step 1: Trigger) | Field values | Description ]

So that the message in Slack looks like this:

:loudspeaker: : The Accounting base in :airtable: has been updated by frozenforum with the following release notes:

  1. Created a new Client Companies table
  2. Converted Client Company field to be a link to Client Companies
  3. Moved company groups to Client Companies table

But instead, the Slack message looks like this:

:loudspeaker: : The Accounting base in :airtable: has been updated by frozenforumwith the following release notes: 1. Created a new Client Companies table
2. Converted Client Company field to be a link to Client Companies
3. Moved company groups to Client Companies table

I cannot get the new line (hard return) after the colon in release notes, although it does show up in the subsequent lines of the record field.

I also cannot get a space after the Name record field, so it says [name]with.

Is this a bug or am I doing it wrong (or both!)?

18 Replies 18

I think you’re on the right trail for fixing this. I have learned that Slack’s version of markdown formatting his dependent on new line characters. How are you adding newline characters now?

I’m not sure how to do that. The only hard returns in the Slack message now are in the description field itself. The Automations window with the message seems to ignore the hard returns that I put in there.

And that’s exactly my question - how are you attempting to place hard returns into the message? I need to see specifically your approach.

I just push the return key in the Automation message window. What is the right way to do that?

I think you need to embed newline characters such as “\n”.

Hmm I tried that but unfortunately the Slack message just ends up looking like this:

:loudspeaker: : The Accounting base in :airtable: has been updated by frozenforumwith the following release notes:
\n

  1. Created a new Client Companies table
  2. Converted Client Company field to be a link to Client Companies
  3. Moved company groups to Client Companies table

For reference, my Automations message looks like this:
image

Hmmm… this works just fine for me. Do you have the “Rich Text Formatting” option turned on in your Long Text field?

p.s. You don’t need the \n line break character in this particular circumstance.

I’m old and I’m confused - when you say “The Slack message ends up looking like this …” are you referring to content pulled from Airtable and sent via script automation to Slack? And secondly, if so, are you pulling from long text fields, single line text fields, or something else entirely?

Sorry for the confusion @Bill.French! When I say “the Slack message ends up looking like this”, I mean that the formatting of the message that I see in Slack as a result of this automation looks like that.

I am pulling the Name field a collaborator field, and the Description field is a Rich Text Formatting field.