Google Calender all day events show as busy

Topic Labels: Automations
648 4
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

I made an automation to create reminders in my Google Cal. They’re all-day events, which by default don’t show you as busy, but when they’re made through Airtable they’re ticked to show as busy.

I couldn’t find a field to change this in my automation.

Can I make it so my all-day events made from automation don’t show as busy?

4 Replies 4

Hi @Sigurdur_Hermannsson,
I see this too. This does look like the default behavior for the API though.

From the API documentation:

|transparency|string|Whether the event blocks time on the calendar. Optional. Possible values are:

  • opaque” - Default value. The event does block time on the calendar. This is equivalent to setting Show me as to Busy in the Calendar UI.
  • transparent” - The event does not block time on the calendar. This is equivalent to setting Show me as to Available in the Calendar UI.|
    | — | — |

I would ask if they can add the Transparency selector to the Automation.

Thanks for the answer. I’ve just sent them an email, I hope they’ll reply.

In the meantime, is there any kind of workaround or quick-fix I could employ?

I only spent about 20 min testing it and could not get Airtable automation to work the same way as creating an All Day event in Google Calendar.

There is an additional app that you can use for free that can watch your google calendar for events created by Airtable, and flip that switch for you. Or remove the automation from Airtable and create the full event in Google Calendar for you the way you want it.

As @Vivid-Squid mentioned above, you can toggle this setting by using — check out this screenshot below:

Screen Shot 2022-09-15 at 3.34.49 PM