Help

Google Sheet to Airtable Data Update Error

Topic Labels: Automations
Solved
Jump to Solution
806 2
cancel
Showing results for 
Search instead for 
Did you mean: 
Gaurav_Gupta
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi,

I am trying to update the existing records in my Table through Google Sheet and everytime I try to run the automation. I am getting an error “Received invalid inputs.”

Record ID provided for Update record automation matches the ID in the Google Sheet along, I am just trying to update one record for now. Please help.

Existing Table

image

Existing G-Sheet

image

Error while testing the automation

image

1 Solution

Accepted Solutions
Marielle_Gueis1
6 - Interface Innovator
6 - Interface Innovator

Hi, the error lies in the field input Record ID you are inputing the Associate ID. It might be the "primary key" of your record, but the Record ID is a different ID. You can find when you expand your record in the url after the view ID or with a formula. Everything is very well explained here (Airtable documentation) . 

In your case, you need to add a step before the "Update record" step. 

It's called "Find Records" and you need to filter your records based on your Associate ID. Then you get an array of records (1 to multiple records) - make sure your Associate IDs are unique.

In the next step (Update Record - the one you already have), you use the record ID found in the previous step (see screenshot), and don't forget to add the field Associate ID and enter the value Associate ID there (by clicking on + choose field underneath Name and Active/Inactive

 Screenshot 2022-12-12 at 16.38.24.png

Another small suggestion is to change the field type Active/Inactive to a single select field called "Type" with two options: 

1. Active

2. Inactive

Hope this helps! 

See Solution in Thread

2 Replies 2
Marielle_Gueis1
6 - Interface Innovator
6 - Interface Innovator

Hi, the error lies in the field input Record ID you are inputing the Associate ID. It might be the "primary key" of your record, but the Record ID is a different ID. You can find when you expand your record in the url after the view ID or with a formula. Everything is very well explained here (Airtable documentation) . 

In your case, you need to add a step before the "Update record" step. 

It's called "Find Records" and you need to filter your records based on your Associate ID. Then you get an array of records (1 to multiple records) - make sure your Associate IDs are unique.

In the next step (Update Record - the one you already have), you use the record ID found in the previous step (see screenshot), and don't forget to add the field Associate ID and enter the value Associate ID there (by clicking on + choose field underneath Name and Active/Inactive

 Screenshot 2022-12-12 at 16.38.24.png

Another small suggestion is to change the field type Active/Inactive to a single select field called "Type" with two options: 

1. Active

2. Inactive

Hope this helps! 

Gaurav_Gupta
5 - Automation Enthusiast
5 - Automation Enthusiast

It worked, thank you so much!