"Ru Script" Automation: Test Failed

Topic Labels: Automations
1438 10
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hey guys,

I’ve just subscribed to Airtable Pro and i’m trying to set automations with “Run Script”. I’ve tried my first automations with a simple scripts as console.log(“test”) and
let table = base.getTable(“Titular”);

let query = await table.selectRecordsAsync();


But when a test it, it keeps getting “Test Failed”.

I don’t know what to do in this case. Would appreciate if someone give me a clue. Thanks.


10 Replies 10
4 - Data Explorer
4 - Data Explorer

I’m getting the message: “An unknown error occurred.”

4 - Data Explorer
4 - Data Explorer

I am facing with the same issues

Welcome to the community, @Luis_Guilherme_Almei! @B13_Technology :grinning_face_with_big_eyes:

When looking at the code in the editor, do you see wavy red lines under any part(s)? If so, those indicate errors, and hovering over the code with the red lines underneath will give you a pop-up indicating the nature of the error.

If nothing is marked as being erroneous, could you take a screenshot of the code and post it here?

4 - Data Explorer
4 - Data Explorer

I have the same exact issue. Looks like script automations are broken. When I test run the default script “console.log(Hello, ${}!);” I get “An unknown error occurred.”

Hi @Justin_Barrett, thank you!

There’s no red lines indicating possible erros. I’m still getting Test failed whichever code i write, as simple as “Hello World”.


4 - Data Explorer
4 - Data Explorer

I have no error in my code but it’s still failed with the error follow my debug console. Please help to have a look at them.
Screenshot 2020-11-30 at 10.25.41

5 - Automation Enthusiast
5 - Automation Enthusiast

I am getting the same issue.

Even the following line is not working :


Interestingly, it is not working in a specific base.
Tried my actual webhook automation script in another base and it works perfectly. But not in the one I actually need it

@Luis_Guilherme_Almei @Amit_Singh1 @B13_Technology This sounds like a deeper issue. I suggest contacting Airtable support directly. They can check out more details behind the scenes and see what’s preventing those scripts from working properly. If it turns out to be something that you can fix yourself, please share the solution here in case others run into the same problem.

I’m suspicious of the quotes in the console.log(''); statement.

Have you tried just…