Help

Updating Date fields and Single select fields in Automation

Topic Labels: Automations
298 6
cancel
Showing results for 
Search instead for 
Did you mean: 
CharlieMullin
6 - Interface Innovator
6 - Interface Innovator

I'm using pre-filled forms in an automation to update a value in the Main table. (The form of course creates a new record in the Updates table.) 

The update form that works is updating a Single Line text field in the Main table, with a value coming from a Single Line text field in the Updates table.

Where I'm have trouble is when the fields to update in the Main table are either a Date field or a Single select field. In those instances, the target field in the Main table does not get updated, and is now empty.

I guess there's a compatibility problem with differing field types. I tried making the field type in the Update table Date fields or Single select fields (with the selectable items in its drop-down.)

I get this error in the automation:

CharlieMullin_0-1709677472404.png

How can I fix this?

 

 

 

6 Replies 6
Sistema_Aotearo
7 - App Architect
7 - App Architect

Hmm not sure. Is it just those two fields not working? Or is the input itself not working?

To me, it looks like Airtable can't locate the record to start the update step.

Common causes are:

  • Too many RecordIDs in the input
  • Wrong Table
  • RecordID displayed as Name instead of ID

Not sure if this helps. If not, maybe a bit more clarification on what the issue is. Happy to help in anyway!

Hm, could you provide some screenshots of your table setups and automation setup?  I tried testing it and it seemed to work fine for me when I set it up like this, so my set up must be different from yours somehow:
Screenshot 2024-03-06 at 12.49.02 PM.png

Link to base

CharlieMullin
6 - Interface Innovator
6 - Interface Innovator

Hey there, here are annotated screenshots that I hope explains what I want to do, and reveals what I'm doing wrong.

Here are the pertinent fields in the Assets table, where the automation updates take place:

CharlieMullin_5-1709741734174.png

Note that the Status TEST field is displaying the value "In Progress", which is a result of the automation executing correctly - almost.

Here's the automation configuration:

CharlieMullin_6-1709741919460.png

Here's the record that was created in the Updated Assets LMSC table:

CharlieMullin_7-1709742081653.png

Note that "in Progress" has been added to the Updated Asset Status field.

But, I want to update the Status field in the Assets table. Here's that configuration:

CharlieMullin_8-1709742282954.png

Note that I'm being prompted to select a value from the item selection that's in the Status field, when I really want to specify the Updated Asset Status field.

CharlieMullin_9-1709742442263.png

How do I get this to work?

Also, the Record ID is specified in the Original Asset Rec ID field of the Updated Assets LMSC table:

CharlieMullin_10-1709742609915.png

Let me know if this is helpful and what else I can provide that would help you figure out what's wrong.

 

 

 

 

 

 

 

 

 

 

Hmm, so you want whatever text value is submitted by the user in the form to appear in the "Status" field in the "Assets" table?  This works for me:

Screenshot 2024-03-07 at 5.41.46 PM.png
If you could duplicate your base without any data in it and DM me an invite I can troubleshoot this for you real quick.  I have a feeling there's something I'm not understanding about your setup and that it'll save us a lot of time if I can just troubleshoot it directly!

Hey Adam, thanks! That would be really helpful. Let me coordinate with my Airtable Admin to arrange for your accessing an empty copy of the base.

Best way to DM you?

Just a private message via the forums works fine!