Help

Re: Attachment download inconsistant

3744 1
cancel
Showing results for 
Search instead for 
Did you mean: 
Valerian_Leber1
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi
We use a script to create airtable records through API.
Attachement (pictures) are stored on a public webserver. The URL is passed by API request and Airtable dowload the attachement on his own cloud to be available in the attachment field.
This solution worked properly for a year maybe.

Since december 2019 we get some “broken files”. It seems that Airtable fails at downloading the attachment ant the attachment appears whit a generic icon instead of a picture preview. The picture can’t be downloaded properly.

It is very inconsistant : we have records with for exemple 4 pictures in the attachment field and one of them appear broken. Deleting the record and recreating it the same way may fix the record. The picture is always available on our webserver.

As we have a long history I could determine that this problem began to occurr on last december.

I read some similar issues on the forum that have been fixed by “patching” the airtable with the support

Can I have any help on this issue?

25 Replies 25
Valerian_Leber1
5 - Automation Enthusiast
5 - Automation Enthusiast

I realised thar in some bases I have a different result : I don’t even have the “broken picture” symbol.
The symbol appear and then after a few seconds desapears… I really need help on this issue as it broke some application we have in production…

This is a known bug in Airtable since mid-2019. Prior to 19-Dec-2019 it was quite reliable.

@Alex.Wolfe – FYI - testing this today, the issue still exists.

Precisely what we see all the time.

Valerian_Leber1
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi, Thanks for you answer.

So you don’t kown any workaround? I was thinking testing the records a few seconds after creation to delete/recreate if incomplete. However that this won’t always work. It looks like there is some cache because even on second try Airtable seems to dowload a corrupted file though the original one is correct.

Any info on the correction of this bug?

Valerian

For one client in the UK I have developed a process that waits minutes and retries up to 6 times and even this has generally failed. Occasionally it works, but the effectiveness is simply not good enough.

Airtable has been quiet about this issue.

Valerian_Leber1
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi,

This issue is still a problem today. Does airtable team have some info on the roadmap to fix this issue?

Valerian_Leber1
5 - Automation Enthusiast
5 - Automation Enthusiast

Well I am struggling with this issue since december 2019.
I had tens of mails with Airtable support and still no visibility on the roadmap to solve this issue. I even reproduces the error with Postman and share it with the support team.

It’s really breaking one of our Airtable application as it is impossible to reliably attach file through API.

Airtable is an excellent product to manually edit databases, but when you work on automation through API, maybe you should look for an other solution.

Valerian

Yep - my findings as well. Here’s more detail on my tests…

Phil_Deschaine
5 - Automation Enthusiast
5 - Automation Enthusiast

I was having an issue with this. If you give the API an invalid attachment url… rather than returning an error, the API accepts the request. Then when you look at the history of the record, it confusingly shows you uploading and deleting an attachment.