Help

Re: Attachments added via API immediately deleted – any updates on this extensively documented issue

383 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Scott_Hoek
6 - Interface Innovator
6 - Interface Innovator

I have an automation that uploads attachments to OneDrive, then adds them to Airtable with their publically accessible URL.  This has worked for for well over 2 years, and a few months ago, randomly stopped with no changes on my end.  No errors get thrown anywhere, and we can actually see an attachment pop in for a second in Airtable and then clear out.  The revision log appears to show me adding the attachment, then deleting it. 

Screenshot 2024-02-19 at 5.16.38 PM.png

After weeks of forking around and thinking I was going crazy, I stumbled upon another form post and Lo!  'tis apparently a known issue.  By even posting this thread, I'm probably going to make one of the veterans of this forum lose their **bleep** mind, but there isn't a solution on any of the many many many existing threads other than "use a different provider" which is clearly not, like, a viable solution. 

Sooooo..... does anybody have any updates on this?  I'd really like to not switch to a different platform as we already pay for OneDrive, and given as this has happened to folks using Google Drive as well I don't even know what to switch to 🙃

3 Replies 3
ScottWorld
18 - Pluto
18 - Pluto

What is the URL of the attachment?

— ScottWorld, Expert Airtable Consultant

Cloe
5 - Automation Enthusiast
5 - Automation Enthusiast

Same here, with google Docs and Make.
It works correctly in another base... 😅

This is a common problem that usually indicates that the file is not publicly accessible at the URL that you are providing Airtable.

— ScottWorld, Expert Airtable Consultant