Error in POST method, "Could not find field \"fields\" in the request body"

Topic Labels: API
5916 10
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast


I am getting an error when using POST via Postman. I am copying the example exactly from the API documentation and changing the authorization key.

I have tried changing the content type, modifying the fields, but nothing worked.

GET method is working.

Why is this?

10 Replies 10

Very strange, I have used Postman successfully in the past to connect to Airtable’s API and also been successful in posting content to the Airtable API via Postman
Please try it via curl and post the result here, I think for some reason Postman and apitester are adding in some extra headers…not sure though.
(Use the same command given in your base’s API documentation)

The curl output should hopefully provide some more insight into what the issue is :slightly_smiling_face:

BTW your API key is visible in the screenshot that you have shared…you will want to blur that part out.