Help

Re: How to send more than 100 records using API?

Solved
Jump to Solution
5363 2
cancel
Showing results for 
Search instead for 
Did you mean: 
Oscar_Diaz
5 - Automation Enthusiast
5 - Automation Enthusiast

I am connected the API of Airtable to Power BI but at the time of displaying the data it only shows me 100 records when the base has more than 1000 records.

1 Solution

Accepted Solutions
Oscar_Diaz
5 - Automation Enthusiast
5 - Automation Enthusiast

See Solution in Thread

22 Replies 22
Andrew_Johnson1
8 - Airtable Astronomer
8 - Airtable Astronomer

The Airtable API uses the concept of pagination.
The response will contain an offset if there are more than 100 records. Include this offset in the next request’s parameters

How can I add these parameters?

Are you using the Airtable Javascript library or accessing the it via their REST API?

If you are using the REST API you need to pass another parameter “offset”

I am using REST API. With what value should I pass the “offset” parameter?

The “offset” value is returned in the response of your first call to the Airtable API under the key “offset”
Take the above returned “offset” value and pass it in your new request.

This is what you want - API Offset Parameter

Reloading the data source sending as an offset parameter and still showing 100 records. The image I send is using POSTMAN to return the json.

Captura.PNG

@Oscar_Diaz,

In the screenshot shown, there is no value shown for the offset parameter, therefore, the API will default to the first 100 records. It is responding exactly how it should.

@Bill.French That the point, what is the parameter that the offset must pass?