Help

Re: What happen to the forms?

646 1
cancel
Showing results for 
Search instead for 
Did you mean: 
Noochy12
5 - Automation Enthusiast
5 - Automation Enthusiast

I've been using Airtable forms for over a year and they were great. I noticed they changed the interface, which doesn't seem to add to functionality but complicated the process. Also, you can't add linked fields anymore. I had mobile browsers set up, and out of nowhere they became useless when they changed this function. I could be wrong but forms can now only be used for new data. Before, I could add a linked field where I could choose an existing record and add/edit data. The only reason I can think of for making this change is because it was easy for employees to interact with Airtable without having to pay the $12 per month but, what I don't understand is, why isn't available to employees who are on a monthly subscription. 

I'm really hoping I'm just not understanding the new form function because my use cases for Airtable have become irrelevant moving forward. 

Has anyone ran into an issue with the new form function? Or, can anyone suggest a workaround? Thanks!!

7 Replies 7
Sherman
5 - Automation Enthusiast
5 - Automation Enthusiast

I've been fighting the same issue the last couple of days, hopefully it's something that's going to get fixed. Everything looks good, just the button for linking is not functional. Is that what you're seeing? 

Noochy12
5 - Automation Enthusiast
5 - Automation Enthusiast

Exactly, all buttons within my mobile browsers that are connected to an Airtable form with a linked record field, which is all of them, will not function anymore. You don't realize how much you rely on something until it's not available, and I definitely never thought twice that it wouldn't be available. This seems like a major setback for Airtable. 

Sherman
5 - Automation Enthusiast
5 - Automation Enthusiast

Hoping this is just a temporary glitch! 

Laura_Adams
4 - Data Explorer
4 - Data Explorer

I'm working in an existing base where I now want to create a new form, but that option doesn't show up in the left sidebar (with the options like gallery and kanban) any more. In another base, it looks like the existing form I have there still exists, and the "form view" option is still in the sidebar. Any ideas where form view is hiding in my other base?

Was just coming here to say I found the issue with my problem, but yours is just as easy. The new add form button defaults to creating an "interface". If you built something, it's probably there.

That said, the link button not working seems to only be a problem in the interface version. There is the option to "create a form view" when you click on creating a new form, and the links are still working in the original version.

This is now what I see instead of "create a view:"

Laura_Adams_0-1706303489231.png

I did eventually figure out how to create a form through interfaces, but it's not intuitive and then it's hard to find how to switch between interfaces (I eventually found the left sidebar has different sections for the dashboard and the form...)

Sherman
5 - Automation Enthusiast
5 - Automation Enthusiast

Really? I have Form at the bottom of that list. When you click it, the default is to make an interface, I just have to click the "Create a form view" instead.

 

image.png