Re: Airtable constantly "Reconnecting"

499 3
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Is anyone else experiencing this? Is this normal or is there an issue going on right now?

7 Replies 7
5 - Automation Enthusiast
5 - Automation Enthusiast

Yes, I've been getting this for a few weeks now. I haven't had time to contact support about it -- largely because my work takes 10 times longer while I watch Airtable spin "Saving..." and "Reconnecting..."

It happens often, but randomly -- so I don't think the size or complexity of my base suddenly reached some threshold. Sometimes activities in the same table will be instant, and sometimes I'm waiting 30-60 seconds for Airtable to catch up. Often it's faster to just reload the page, and when I do this I find my changes saved.

It's happening on different browsers, and regardless of changes to my DNS settings. (Was using encrypted DNS, but changing back to defaults didn't make a difference.)

5 - Automation Enthusiast
5 - Automation Enthusiast

Edit 2024-05-16: Nope, the below doesn't do squat. The speed improvement I saw must have just been the normal sporadic nature of the problem. I've further noticed that Airtable regularly spins "...reconnecting" even when it's sitting doing nothing at all.


I'm not ready to call this a sure thing yet, but it's promising:

Since a page refresh (F5) always instantly loads the updated Airtable page with my "pending" changes saved, I wondered about a cacheing issue.

When I cleared the browser cache, Airtable would become responsive again... for a while.

If you open a browser's Developer Tools, there's a Network tab where you can check a box to "disable cache."

Keeping the cache disabled while working in Airtable, so far, seems to solve the problem.

Detailed instructions for disabling cache -- and a plugin option -- available here: How To Disable Cache in Chrome, Firefox, Safari, and Other Browsers (

I'm interested to hear how anyone else fares.

Update: unsurprisingly, the Windows "desktop app" -- which appears to be an Electron app, so, just a Chrome window -- behaves exactly the same.

5 - Automation Enthusiast
5 - Automation Enthusiast

Solved: it was my Spectrum router.

While troubleshooting this, I tried to change default DNS settings at the router level, and found that my Spectrum router would not save any changes to DNS values.

Spectrum support recommended an "upgrade" to a newer router that would allow such changes.

The new router is, in fact, a downgrade in configurability, and the usual admin area is not even accessible via IP. It can only be configured -- at a very basic level -- via their website. Apparently the configurations are all centrally managed.

Anyway, it turns out the old router, model RAC2V1K, is known for "pausing."

The new router, which is also labeled RAC2V1K but identified in settings as SAC2V1K, doesn't seem to have this problem.

My constant "reconnecting..." issue with Airtable is gone. Not sure why it suddenly started happening after a couple of years with that router, but... [shrugs.]

Did you have to change any settings or just change routers? We have an Orbi Netgear Router and are getting Reconnecting and Saving pauses very consistently.

No, I didn't have to change anything. I connected the new router and the problem was solved. Your mileage may vary, but it might be interesting to swap routers and see what happens.

Thanks for the info and for the reply!