Attach File with Zapier Email

Topic Labels: Integrations
4841 8
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

Hi All,

I made a Zap for sending a new rows in a view by Zapier email. In my Airtable row is a column with files.
My problem is that I could not figure out how to send an email with attachement. The only possibility i found was to send the file in the coulumn via airtable url to the file?

Does anybody know how send an email by zapier mail as attachement?

This are the options given by Zapier, none of them is an attachement option??

Airtable Zapier E_mail Attachment

8 Replies 8
6 - Interface Innovator
6 - Interface Innovator

Can anybody help me please? :flushed:

Hi @Avi_Doe

It worked great for me - even with more than one file (they seem to be sent in a Zip file):

Screen Shot 2017-10-07 at 14.17.28.png

Thanks Julian!
It worked with the “url” for attachement.

Kind regards

Hi all, I’m using @Julian_Kirkness set up, which seems to trigger the outbound email nicely but the attached file is always type ‘file’ which makes it impossible to open. When there are multiple files to be attached, then it zips it together but still are type ‘file’ when uncompressed.

Is this something happening to you too? Any idea what might be wrong?

Thanks in advance,

6 - Interface Innovator
6 - Interface Innovator

This seems to be a new problem. I also have it since today. :confounded: I hope it will be fixed very soon!

6 - Interface Innovator
6 - Interface Innovator

I found a solution with embedding dropbox into the zapier task.

With dropbox I can add a file extension and even rename the file. But this workaround is limited to one type of file format. But for the moment I can live with it.


I had this same issue. I found that I could add the URL field to the body of the email. At the end of the day, it allow the user access to the document although not as ideal as it just showing up as an attachment.

5 - Automation Enthusiast
5 - Automation Enthusiast

I am having a similar problem: I am sending an email to Airtable, and want the attachment from the email to be part of a record. However, it is not showing up there.

This is the zapier test:

There are actually two attachments - both of which have legit names
But this is what shows up in the airtable record.

image ![image|339x423]