Help

Upcoming database upgrades. to improve our reliability at 03:30 UTC on Feb. 25 / 7:30pm PT on Feb. 24. Some users may briefly experience slow load times or error messages. Learn more here

Date changing when creating new record though Automations

Topic Labels: Dates & Timezones
359 1
cancel
Showing results for 
Search instead for 
Did you mean: 

I am using Airtable as a Health and Safety Database for my Organisation.

I have one Table to record all the Prestarts my teams do, regardless if they are electronic, by paper, or a mix. (Prestarts)

I have another Table that essentially is a form for the Electronic Prestart. (Prestart Form)

I also have an Automation set up that when a new record is created in Prestart Form, it creates a new record in Prestarts, and inserts the data such has Date, Site, Team Leader.

This is working well with the exception of the date that is created in Prestarts is a day behind. I could just change the date manually… but that defeats the purpose…

HELP!!!

(Initial Form that is filled out)
image

(Table Created from form)
image

(Automation Trigger)
image

(Automation Action)
image

(Prestarts Created Entry)
image

1 Reply 1

I think you have a timezone mismatch. If you go to the table the form is from and open up the Date field, try turning on “Use the same time zone (GMT) for all collaborators”.

Screen Shot 2021-03-24 at 10.49.33 AM

I’m guessing your from date field has this setting off?

Unfortunately, it seems the automation deals exclusively in GMT. So, essentially, the automation is taking your local time, converting it to GMT (I am guessing your local time is ahead of GMT) and then inserting the date of that time in your receiving date field.

If the GMT time for the time someone filled out the form is during the previous day you get that date instead of the one you want. : P

Checking the box should “trick” the automation into thinking you already took care of the time conversion and you don’t need any “help”—even though you’d rather it didn’t bother in the first place!