Re: Integromat - Saving Gmail attachment to Airtable

1028 0
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hi! looking for help using Integromat - i’ve been trying to use Gmail Watch function and extract the attachment to Airtable but couldn’t get it working.
What should I choose ? just click “choose” and select the attachment doesn’t seem to work. If I click Map and then add item, what should I select in the file URL? I selecting the attachment but it doesn’t work either.

Thank you for any advice!

16 Replies 16
6 - Interface Innovator
6 - Interface Innovator

Hi Keith, did you ever get this working. I’m trying to get the same from Google Drive but haven’t got the correct data or result in my attachment field.

11 - Venus
11 - Venus


You might want to also try Facebook, where there is an Integromat Community. They now have support people that are associated with Integromat, assisting users/members. They have been very helpful to me, a beginner.



Looking at this, I think it’s because the Gmail app in Integromat is returning the actual file whereas the Airtable attachment field wants a URL of a file to load (which isn’t available). I would be delighted to hear there’s a solution to this - maybe a support request to Integromat is in order…

OK - I contacted Integromat and they suggested saving the file to Dropbox first - and then copying from there to Airtable - but I couldn’t get this to work on my Dropbox account.

However, I tried with Google Drive and have a working solution - here’s the overview of the Scenario:

Screenshot 2018-11-12 at 12.40.06.png

Note that I am also using an Iterate Attachments Gmail app which will allow you to do something with each attachment. Each is then stored in Drive, a record is created in Airtable and then I delete the file from Google Drive.

Hope this helps!

Hey Julian, I know that I’m way late to the conversation, but would you mind showing me what “value” you put in the Airtable dialog for the attachment field? Like this:


I can’t find the right output of the Google Drive (upload file) block to make this work. I know the file is getting saved in Drive and the record gets created in Airtable, but no attachment.


Hi @augmented

To be honest I’m not certain - I don’t have this scenario any more. However in a similar one I am using the Direct download link to pick up the file for Airtable. If this doesn’t work it could have something to do with your Drive settings.

Also it may be worth trying the Get a share link Drive module.


10 - Mercury
10 - Mercury

Thanks Julian, will try your suggestions.

Hey Julian, just thought I should let you know that one of your suggestions was the answer. I needed to make the folder in Drive viewable with link, instead of private to me.

Thanks again!!!

5 - Automation Enthusiast
5 - Automation Enthusiast

Related question: I have an integromat scenario which retrieves a labeled email, creates an AT record, and then interates throught the email attachments to add them to that record. However, if there are multiple attachments, when i use Integromat’s UPDATE AT RECORD action, it REPLACES the current attachment with the new one (each iteration) so in the end I only have the last attachment, not all of them. It seems like AT should ADD to attachments, not replace, since that field allows multiple attachments. any solutions/ideas? Thanks.

Hey Sarah, can you please share a screenshot of your scenario? Also, I would encourage you to post your Integromat related queries on the Integromat community to get faster help. Here’s the link:

I ran into the same problem with such a use case

I cant figure out how to create one record per email and add multiple email attachments in one attachment field in Airtable

This setup just iterates through each attachment overwriting the previous so you end up with only the last attachment in the field
If I add an array aggregator then I still can input only individual file URL and ID which gets the same result
Maybe mapping could solve it but I have no idea how to.

Hey! So this one is a bit complicated but once you see the solution, you will realize it makes sense.

In your Array Aggregator set up, you need to select the Gmail > Iterate Attachments module as the source module. Why? Because this is the module that is iterating the attachments array from Gmail to generate multiple bundles of data. When you select the GDrive module as the source, the Array Aggregator takes 1 bundle and aggregates it, instead of taking all the bundles generated by the Iterate module.

Next, under Target Structure type, you will see an option Record: Attachments AFTER you connect the Airtable module to the right of the Array Aggregator. This is because now Inetgromat can automatically generate the data structure of the array that is accepted by the Airtable module.

Lastly, you just need to map the elements (Name and Web Content Link) from GDrive to create the requisite array. See the screenshot below:


Pro tip: You can use text functions to modify the file name directly in the Array Aggregator module as shown below:


Happy Automating! :slightly_smiling_face:

Great - thanks! This got the necessary result. Still learning how iterating and aggregating arrays works so this was a good lesson!

You’re welcome! And you can learn all about Iterator and Array Aggregators in 12 minutes, check out this free course!


Hi @Arpit thanks for this response to @Krisjanis_Dzalbe questions about getting multiple gmail attachments into an Airtable record.

I think i now have this working, but the Airtable record winds up with its attachments field populated with a link to my GDrive - I want the file natively in Airtable so my other Airtable users dont need permissions on my GDrive, and also so I can use the file image thumbnail that Airtable generates.

Do you know how I can achieve native Airtable file attachments in a single Aitable record, populated from multiple Gmail attachments?


Thank you so much for noting this…I’ve been working on this problem for TWO DAYS!!! Found your suggestion to change the drive folder permissions to viewable with link - that fixed it!