Help

Re: Markdown doesn't work in rich text long text fields?

3013 0
cancel
Showing results for 
Search instead for 
Did you mean: 

According to this support article, it says that we can use markdown formatting in any “long text field with rich text formatting on”.

However, this doesn’t work.

We have a long text field with rich text formatting on, but when we add markdown syntax into our text, nothing happens.

For example, if we type the following into our long text field:

**test** *test* test

We would expect the results to look like:

test test test

(Notice that the 1st word is in bold, the 2nd word is in italics, and the 3rd word is plain text. That’s what we would expect.)

But everything just stays in plain text, and looks like:

**test** *test* test

Thoughts on how to get this markdown formatting to work within a rich text long text field?

14 Replies 14

Thanks for researching this so thoroughly! :slightly_smiling_face: Do you know how we can report this as a bug to Airtable?

As @kuovonne said, half of the fields are working, half are not.

This is a particiular problem as I was hoping to finally replace my old URL fields with markdown,

In theory this should take 10 seconds, copy the URL column, paste it into notepad, add [Link] and then wrap the link in

The problem is, pasting [Link](http://www.example.com) into the rich field doens’t actually turn it into a link, it interprates it as raw text.

I was hoping maybe it was doing something similar to TinyMCE, and you could paste actual A HREF links into the field, but it strips all tags and pastes as plain text, so that doesn’t work either.

Anyway, I’m sure they’re aware of it and working on it.

Correct. This is a suboptimal mess.

To actually use a long text field as a pretty link field, you have to:

  1. Enable Markdown on the field
  2. Add the link via the API or a script block
  3. (I think) You must also format the links as shown below and I believe the newline characters are required to make it pretty in a cell, and this is pretty much validated by @dave_brand’s video.

[CNN][1]\n http://cnn.com[1]: \n

There are three ways to create pretty links in rich text fields:

  • through the user interface button
  • through the API (standard API or Scripting block API), using either syntax
  • through Integromat/Zapier, (using the multi-line syntax), per @dave_brand’s update to his video that @Bill.French links to.

An ugly workaround if you have to bulk insert several records at once is to put the markdown text in a plain long text field, and then use the scripting block to copy the text to an rich-text field.

Chandan_Chauhan
4 - Data Explorer
4 - Data Explorer

It’s a bug. Their document lists the markdowns that are not working currently.