Re: Shared View Problem in mobile device web browser

1149 3
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hi. When i open the share view link at desktop browsers, it works fine. all options ( download .csv) are available. But when i open the same link at chrome browser in mobile device, those options are not been appeared on the screen . Please give any advice.

7 Replies 7

What mobile OS are you using? Have you tried other mobile browsers?

I have a similar issue on Galaxy Note 10 AirTable App. i have a linking table that works fine on desktop but on mobile I can see the linked data on existing records but I cannot modify or add new records that are linked. It just says loading from the other table. I can view the other table in mobile by iteslef but when trying to modify data in the table that links to it I cannot change or add from the linked table. As mentioned desktop works as expected. I do see a “loading” text sometimes in area where linked data should be. Im logged in with the same google user on desktop/mobile so that should not be permissions issue.

Welcome to the community, @Kenneth_Larkin! :grinning_face_with_big_eyes: Your situation is actually very different from the one mentioned by @oppus_service, who was talking about a shared view. Your issue is with the native Airtable mobile app, which doesn’t have the full feature set of the desktop/browser applications. However, I’m surprised that it doesn’t let you modify linked fields. The iOS app allows for creating and updating links without any issues.

One thing you might want to check on your linked field (using the desktop/browser version) is whether you have the “Allow linking to multiple records” option active. If so, that will only allow one link in that field, and you’ll have to remove the existing link to add a new one. In the iOS app, removing a link is done by swiping the link to the left, which exposes an “Unlink” option beneath it. Perhaps it’s similar with the Android app.

Thanks Justin, If that were the issue then I would have the same problem on Desktop also. Its it a single select (not multiple). More specifically its only an issue when shared in another base. If its in the same base its fine.

Base 1 has a list of all records and then has a specific Grid with a filter to show only x type records. It is this Grid that is then shared with Base2.

Base 2 then sees this filtered Grid and has a second table that is linked to this first table. It is this second table that cannot see the linking on mobile to the first table. Works fine on desktop though.

Could a developer look into this.


Ah, you’re using the newly-added sync feature. In that case, then that explains why you can’t see the details. Under the current implementation, syncing a table between bases only provides the target base with a read-only version of the source table. That’s not a mobile-specific limitation. That’s a limitation of the current sync feature.

If that’s not what you’re doing, they would you be able to share screenshots of your setup? I may be misunderstanding how things are laid out.

Just to clarify, this isn’t a user community forum, and I’m not an Airtable employee. I’m a user, just like you. :slightly_smiling_face: While a few Airtable staffers post on occasion, this isn’t the place to go for tech support. It’s best to contact Airtable support directly if you believe this is a bug in the software.

4 - Data Explorer
4 - Data Explorer

Thanks for clarification, thought I was onto their support as I clicked the support link.

I only want read only access in the target base. I am using base 1 as the master and base2.table1 to sync in from the master and base2.table2 to show the names of users in a drop down that come from base2.table1.

Works perfect on desktop but on mobile when I try to select drop down on base2.table2 to select a user name there is no drop down. If I add the user on desktop and then go to mobile I see the user on mobile but cannot change to any other user as there is still no drop down.

I think this is a bug but where do I report it.


Thanks for the breakdown of your setup. I created something similar, and was able to link to records on the synced table without any issue in the Airtable iOS app. This sounds like it might indeed be a bug with the Android version.

In my message above, the text “Airtable support” should be highlighted in blue. That’s a link that will take you to the Airtable support page. Scroll down, and you should see a form where you can submit your request for assistance.