This Product Ideas board is currently undergoing updates, but please continue to submit your ideas.

Update error message when updating a record fails

Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast
Status: New Ideas

I have an automation trying to update multiple fields of a record. Sometimes it fails and give me this error :

Error: Field "fldKGWwykYE5qbRTG" cannot accept the provided value.

Could you update the error message to provide the Field name instead of ID.
Logging the "provided value" could also be very precious.
It will be very helpful for debugging to understand what happened and how to avoid it in the future.

Thanks a lot!

18 - Pluto
18 - Pluto

I agree that it is way too difficult to find the field IDs. There is actually a very secret & very hidden & very difficult way of finding the field IDs. All the way to the right of your tables in Airtable, you can click on “Tools” and then choose “Manage Fields”. Then, on the next screen, all the way to the right, there is a tiny little preferences icon. Click on this and you will be given the option to reveal the field ID’s. However, even after you reveal the field IDs, there is still no way to sort by the field IDs or search by the field IDs. 🤷🏻‍♂️

12 - Earth
12 - Earth

You can use this small script to find a field by ID or part of it.
Of course, it's just a workaround. The idea is good.


let f_id=await input.textAsync('field ID or part'); 
let fid=arr=>arr.filter(el=>;


Btw, it's not clear for me, whether free plan users can use scripting extension. I saw comments on facebook page that scripts are unavailable on free plan. But when I've tried my personal, non-work account, created long time ago, scripting was available.