Automation not working correctly with formula field

I have a formula that returns a url like the one below. I’m trying to send the URL to a Slack channel when a condition is met, however, Airtable doesnt give me the option to choose the URL string, it only gives me the option to insert the LENGTH. How can I simply get it to send the string?

2021-03-19 07_40_38-USBets Network Evergreen_ Affiliate Links - Airtable

IF(
SEARCH("NJOnlineGambling", {Website}),
"https://www.njonlinegambling.com/wp-admin/admin.php?page=easyaffiliatelinks#/",

IF(
    SEARCH("PennBets", {Website}),
    "https://www.pennbets.com/wp-admin/admin.php?page=easyaffiliatelinks#/",
      
)

)

This is a puzzling situation.

Have you tried re-running the test for the trigger? Can you share a screen shot of the result of the formula field for the test record, including the column header?

Are you sure that the formula is exactly as you included in your post? It looks like there is an extra comma after the second url.

Hi, the actual formula is as follows:

IF(
SEARCH("NJOnlineGambling", {Website}),
"https://www.njonlinegambling.com/wp-admin/admin.php?page=easyaffiliatelinks#/",
IF(
    SEARCH("PennBets", {Website}),
    "https://www.pennbets.com/wp-admin/admin.php?page=easyaffiliatelinks#/",
    IF(
        SEARCH("MIBets", {Website}),
        "https://www.mibets.com/wp-admin/admin.php?page=easyaffiliatelinks#/",

            IF(
                SEARCH("COBets", {Website}),
                "https://www.cobets.com/wp-admin/admin.php?page=easyaffiliatelinks#/",

IF(
    SEARCH("HoosierStateBets", {Website}),
    "https://www.hoosierstatebets.com/wp-admin/admin.php?page=easyaffiliatelinks#/",
    IF(
        SEARCH("TNBets", {Website}),
        "https://www.tnbets.com/wp-admin/admin.php?page=easyaffiliatelinks#/",

        IF(
SEARCH("USBets", {Website}),
"https://www.usbets.com/wp-admin/edit.php?post_type=geol_cpt&orderby=title&order=asc",
IF(
    SEARCH("SportsHandle", {Website}),
    "https://www.sportshandle.com/wp-admin/edit.php?post_type=geol_cpt&orderby=title&order=asc",
    
 IF(
    SEARCH("MountainBets", {Website}),
    "https://www.mountainbets.com/wp-admin/admin.php?page=easyaffiliatelinks#/"
    

)
)
)



    )
    )
)

    
         )       
    )
)

When I tick a checkbox in another field the automation will send a message to Slack. This works, but for some reason it won’t let me choose to display the output of the formula in the automation builder. Can you specify which screenshot you’d like to see again? I’m a little confused. Thanks.

I retested it and it’s working now, not sure why, but thanks!

Glad you got your automation working.

By the way, if you ever need to edit that long formula field, considering using a SWITCH function instead of all the nested IF functions.

I’m having this identical issue. In fact, none of the computed fields, let alone the one I’m hoping to use, in my table are available to ‘insert’ in the automation message. I have re-tested the data trigger many times and can be sure that isn’t the issue, here.

It almost seems like this isn’t a bug, and that inserting a Fx field is not supported.

1 Like

Yep same here! Any way around this except using Zapier or Integromat?

What happens if you add another formula field that just mirrors the problematic one? Still limited to just length inserts?