filterByFormula : Search on Filtered fields (API integration for Adalo)

Hi!

I am trying to extract a filtered view from a specific field (list of document = to the user ID) and have this user from a search bar Search() or Find () a document tag .

AND(
Search(‘Search Term’, {doc-tag}),
({company-id}=‘User company-id’)
)

I managed to make these formula work independently, but combining them has been hectic for me… Once the query is executed, the issue is that the view keeps showing all documents from all companies, but after typing the first tag search, the list of documents then sticks to the user company-id.

Any tips on that issue?

Thanks!

Hi @Tim_Khan,

Thanks for your question!

I’m not sure exactly what you mean by this – would you be able to clarify how the results you’re getting are different than what you’re expecting? Thanks!

One tip for debugging filterByFormula API calls is to add this formula as a field to your base in the Airtable UI, so you can verify that the formula is working as intended.

Are you prompting users for a search term, and then sending that search term in the formula? That is what I’m assuming based on your question, but want to make sure I’m understanding correctly! It might be worth double checking that the search term entered by the user is being properly inserted into your formula, so I’d recommend checking the value of your filterByFormula param before making the API call to make sure it’s what you’re intending to send as the formula.

I hope this is helpful! Feel free to follow up with more details if this filterByFormula param is still causing you trouble :slightly_smiling_face:

Hi Erin thanks for you reply.

Well I am trying to filter a document list (view) with the user company ID and then have that user search a document tag. It seems that at a first login as nothing has been typed (yet) in the search bar, the query is not yet triggered (maybe because as their is no search term typed, the AND formula returns false), it’s only after the user types any string that the query is enabled. I guess I should check that issue with ADALO directly or think about an other formula that could work in that case.

Hi Tim, I’m having trouble with multiple inputs in a filterByFormula query in Adalo as well. When I test out the formulas directly in Airtable, they work, but not when they’re sent through the API.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.