Roll up of time tracked on a project

#1

Using airtable to track the time we spend on projects for billing purposes.

I am working on gathering data sets to review whether certain types of project are profitable. I have a field for duration (using the time tracking block and h:mm:ss format) which creates a record that is linked to the project record. Im looking for a way to roll up all the time tracked on one project from different collaborators into one field to see the overall time spent on a project.

I thought I could format it the same way we have our total revenue formatted Rollup > Payments > Payment Amount > SUM (values) but with the h:mm:ss format it just returns an error message.

I know I can view the overall time in a summary view when grouping/filtering views to certain projects but it would be ideal to have these numbers automatically added to the project records so that more fields can be used to calculate profitability.

Thanks in Advance!

0 Likes

#2

I ran a quick test based on how I think your base is set up, and I’m not getting an error. It correctly summarizes all of the durations for each project. Here’s how I set mine up:

My first table is Time Tracking. I don’t know what you’re using for your primary field, so I just put dummy text in there. The second field is a date field, used by the Time Tracking block to store the start time. The next field is a link field pointing to a Project table, and finally I have the Duration field where the time tracker puts the recorded time spent. I didn’t include any collaborators, as that doesn’t seem relevant to the necessary calculations.

After adding some time entries, I moved to the Project table and added a “Time Spent” field, which is a rollup, pointing to the entries from the Time Tracking table, collection from the Duration field, and applying SUM(values). This was then formatted to be a duration format (h:mm:ss). After saving, the proper results appeared, summarizing the recorded time for each project from the Time Tracking table.

Does that sound similar to what you’ve done?

0 Likes

#3

It does, but it actually worked this time, not sure what I was doing wrong. Thanks!

0 Likes