[SOLVED] Visual Studio API Error

I want to access a airtable table through my app i’m making. I have the community airtable API installed into my project, but setting up the thing is a whole new task.

I’m trying to add a new item to the table through the app currently. I don’t think the code is incorrect because I used it off the documentation of airtable visual studio api.
Here

In all the examples of how to use it, there are these two lines that are needed.

readonly string baseId = YOUR_BASE_ID;
readonly string appKey = YOUR_APP_KEY;

I think i’m putting in the wrong numbers somehow. So I put my api key for my account in the second line and the base id for the specific sheet in the baseId line.

Ex.

const string baseId = "app********"
const string appKey = "key********"

If you know anything that would be helpful. Thanks.

Edit: If you anymore info or screenshots I can send them.
Edit 2: Turns out that it’s actually not my fault. The api is broken I think.

https://api.airtable.com/v0/*********/Codes?api_key=*********

This is how you access the files. But the visual studio API does this instead:

https://api.airtable.com/v0/*********/Codes/*********

I legit have no idea how I fixed it, but I did. Sorry if you have the same issue.

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.