Synced field change configuration

Hi, I have been using the Sync function successfully for a while but today a field I created in the originating base as a % turns up in the synced base as a single line text field. No amount of resyncing seems to help. What could be going wrong?
Thanks,
Jonathan

Yes, unfortunately, you’ve stumbled upon one of the many bugs/problems in Airtable’s syncing feature.

Unfortunately, like most of the features in Airtable, the syncing feature is “half-baked”, meaning that the Airtable engineers never finished thinking through the sync feature to completion… but they released it to the public anyways.

Airtable doesn’t fully support lookup fields in their syncing solution, and they don’t fully support formulas based on those lookup fields either.

To see these problems in action, check out the screenshots below of a source base and a destination base.


In the source base, I have a lookup field which is a percentage field, and a formula field (which simply equals the percentage field).

In the destination base, the lookup field converts itself into a single line text field. This is wrong. It should stay as a percentage field.

In the destination base, the formula field only shows the first value in the field, not all the values. This is wrong. It should show all values.

So, like all of Airtable’s problems, the only way to workaround these issues is to handcraft your own custom solution, either by writing your own custom Javascripts, or by using a low-code/no-code automation platform like Integromat.

I do all of my custom solutions using Integromat, and I am also an Integromat Partner if you need to hire someone to help you set it up.

Also, I think it’s very important that everybody email support@airtable.com about these gigantic problems with syncing.

As you can see, the problem with formula fields is arguably an even bigger issue than the problem with lookup fields, because the formula fields are actively DELETING INFORMATION that should be seen onscreen!

Thanks Scott, I do have a simple manual workaround but it is a bug that should be looked at. I have said as much to Airtable support as suggested.
Thanks again.

1 Like

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.