Syncs and Automations

Hello! I have a base - we will call it base 1. It contains visible and non-visible records.
I have a view within the base specifically for “visible” records. When a record changes from non-visible to visible, only records in that view are seen.

I have synced the “visible” view to Base 2 and set up an automation that when a new record enters the view, it creates a new record in table 1 within Base 2. All is working as expected.

When a record is updated in Base 1, it updates, as expected via sync to Base 2 visible view. Working as expected.

What is not working.
I am attempting to set up an automation that when a record in Base 2 Synced visible view is updated, it updates the fields in the “new” record within table 1.

I keep getting an error that the record does not exist.

Any tips? Thank you!

Hi Danielle, yeah, I’ve hit this a few times. I usually get around this by creating a formula field with RECORD_ID() for the table in question and then using that specific field in the automation

(Can’t be sure that we’re having the exact same problem, but the symptoms do sound similar)

Any chance you could share some screenshots of your automation?

Sync is one way and communicate between base. Automation works inside base. Maybe some workaround exists to update a record in other base, but I think if you want to track changes made in Base2, you should setup another sync from Base2 to Base1. Destination table will be other, but you can set up automation that will update records according to change in that destination table.