Help

403 Use Column ID: false / Invalid permissions when connecting Make and Airtable

438 3
cancel
Showing results for 
Search instead for 
Did you mean: 
Lee_
4 - Data Explorer
4 - Data Explorer

Hello!

Hello!

I am new to Airtable and Make.com… have tried to make 2 steps work for a month and it has not been working…

THE GOAL: What I am trying to do is to extract the transcript from a video file, so after I can produce a written article, a title for the article and the video, and a description for Mr. YouTube.

ERROR: Use Column ID: False or 403

STEPS: (STEP 1: connecting with Webhook => OK). STEP 2: Getting a record from Airtable and put it into make to transfer the info into Google Drive (video transcript).

Problem in STEP 2
I have checked the names and IDs and I don’t know what I am missing. My administrator did the same operation and it showed the “Use Column ID: false”, but we didn’t have any problems or errors until now. I have re-written all the code, redone the tables and the whole process. Have updated all my permissions and the token on Airtable. I have 1 test record.

ID formula: RECORD_ID()

Screenshot 2024-06-26 at 18.20.20.png

Screenshot 2024-06-26 at 16.39.23.png

Screenshot 2024-06-26 at 15.53.05.png

Screenshot 2024-06-26 at 15.58.23.png

Screenshot 2024-06-26 at 16.44.54.png

Screenshot 2024-06-26 at 17.03.36.png

Screenshot 2024-06-26 at 16.44.27.png

Screenshot 2024-06-26 at 16.42.22.png

     

    

@ScottWorld @Olpy_Acaflo What can I do to solve this issue?

3 Replies 3

Hmm, you shouldn't need to deal with permissions / tokens at all actually, when you set up the connection in Make that's already handled for you when you grant access to the table

Does the connection you're using in this scenario work in any other scenarios? 

Sachin_191
6 - Interface Innovator
6 - Interface Innovator

Hi

We'll first ensure that your webhook successfully captures the video data. Next, we'll verify that Airtable retrieves the correct record by double-checking field names and IDs. Once that's set, we'll use Make.com to transfer the transcript to Google Drive.

For Step 2, here's a concise approach:

  • Confirm Airtable's API key and base ID.
  • Ensure field names in Airtable match the expected schema in Make.com.
  • Test the webhook with a sample record to verify the data flow.
  • Adjust Make.com settings to avoid the "Use Column ID: False" error.
Lee_
4 - Data Explorer
4 - Data Explorer

Dear @Sachin_191 @TheTimeSavingCo 

First of all, thank you for taking the time to help me with this challenge.

I think I got it... I had to put the RecordId manually along with selecting it in the pink fields. But I don't know why the "recordId" is not pulled automatically. Is this normal? If not, what should I do?

STEPS I TRIED:

  1. I checked this step already 7 times and since I am new I do not understand much (especially technical things that might be super basic)... This webhook is unique to this flow, so it is not used in another flow or scenario.
  2. Please see images for ID data.
    1.  in Airtable's Automation #1: RecordID = recDSCVPk2j4vih3U
    2. in Airtable's Automation #1 + Airtable Record 8  : Airtable RecordID= recfSGJsT|3hSkw60
    3. in MAKE in step2 connection to Airtable: RecordID= recfSGJsT|3hSkw60
    4. in Table that connects with the webhook in Make: RecordID= recfSGJsT|3hSkw60
  3. Does it have to do with the code? I wrote it first the "recordId" so it would be autocomplete:
    1. (1) const webhook =(webhookURL + "recordId" + recorded);
    2. And later added the “?” and the “=“
    3. (2) const webhook =(webhookURL + "?recordId=" + recorded);

 

Questions: @Sachin_191 

I am sorry but I don't understand where are the settings to avoid "Use Column ID: False" error, how to know for sure what is the schema in Make.com, I already tested with a sample record from row 8 (in images)