Re: Automation - update record from one table to another - receiving error Received invalid inputs.

837 3
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

I cannot figure out what im doing wrong.. I want to update the table "TENANTS" when the record in the table "tenants (this syncs with tenant base)" is updated. I keep getting an error on the last step "Received invalid inputs." .Any help would be appreciated!





5 Replies 5
7 - App Architect
7 - App Architect

Hi @Hll
When you are using the find record step, your input is invalid as the error code suggests. The Airtable Record id needs to be inserted there. However, you are watching multiple tables that are being updated so might not work as intended. If i can recommend a workaround, it would go like this:

Trigger: When a record is updated 

Action: Conditional logic

If Tenant ID name contains: Tenant ID

Update record.

thanks! When you say I am watching multiple tables you mean im watching one table and wanting to update another?


How do i insert the record ID for the record i want to update?

Hi @Hll,
I apologize for the typo. I meant when you are watching multiple fields in a table. I can see with the screenshot you are watching 5 fields (Tenant ID, Companies, LOS URL etc.)

To answer the second part, when using the Find Record action, you should use the 'Airtable Record ID' instead of 'Tenant ID'. But it will not work for the same reasons explained above. As you are watching 5 different fields, when any of those records are updated, the 'Airtable Record ID' will not be specific enough (Personal note: I only use the Find Record feature if all other possibilities don't work).

Have you tried the workaround I suggested? Let me know if it helps or if you find another way, so other people encountering a similar issue could find a solution 👌

I tried your suggestion, when i did that i still wasn't able to update the right cell in the target table im trying to update - i think this is because i can't tell airtable which record ID i want it to update. This is what i did for your suggestion. Any other ideas? I looked at this help article -, and i noticed the "note" - how would i return the record im trying to update?


thanks for your help!!




Hi @Hll,

The reason it's not working is the Record ID in the conditional logic step needs to be the 'Airtable Record ID' in the trigger. It cannot be the Tenant ID as it's a long field type and not a Record ID.