Re: Creating the record failed due to insufficient permissions

5652 2
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hey there!
I’m having this issue when trying to create a record into another table within an automation.
I have creator permission in both tables and a paid plan.

I’ve tried everything on this link Error in Automations
and i’m now figuring out if that last comment is what is happening to me, though that would mean i cant create records if im leaving lookup or linked record field empty.
In that case, Is there any way of doing both of them?

6 Replies 6

Hello and welcome @ardilla_4!

Could you give a little more information about the automation you are trying to create? What is the trigger, and what actions are involved?

For context, the error you are receiving can happen when the cell value for the linked record is not a valid primary cell value for the linked table (e.g. if the primary column in the linked table is a computed field).

If you’re working with a computed primary field, you could add a Create Record action prior to your Update Record action in the Automation, then point the Update Record action to the record from the Create Record action’s output. Note this will always create a new record, for example, even if the record you’re linking to already exists.

Let me know if that helps, or if not- I’d love to help more once I understand your automation a little bit better.

Hi Rose, I’ve just started with Airtable and I have found very limiting the Link field, I have the same issue reported by “ardilla_4”, I’m getting: “Updating the record failed due to insufficient permissions.”
My “calendar” table is where all the calculations are done and includes 8 different destinations fields (Dest1, Dest2, etc), I linked them to my table “currencies” where primary field is the airport code, the lookup field on calendar table looks for the currency on currencies table. The automation works for the first destination (Dest1) but not for the rest.
Dest1: IAD (Washington), Dest2: IAH (Houston), Dest3: FCO (Rome)
Currency1: USD (Washington), Currency2: USD (Houston), Currency3: EUR (Rome)

I didn’t get the solution that you suggested on your previous post about Create Record action prior to your Update Record action, could you please show an example?
Thanks for your help

Hello @Airtable_Padawan!

I’d love to help try and figure out what is causing the error in your automation workflow! It’s bizarre that the first run of automation is working, and the rest aren’t:

This makes me think the automation’s “Update record” step is the one causing the problem. At this point I think I might need to see your Automation’s run history to really get to the bottom of things.

Could you please share a quick a 1-2min screen recording, or screenshots, walking through the Automation workflow and run history (especially the record throwing the error) so I can speed up the troubleshooting process? If you aren’t comfortable sharing feel free to DM me directly, or contact customer support via chat here.

Hi Rose, thanks for your response, I have turned to code in order to bypass the issue so I have deactivated the automation.

The problem with the automation is basically is as you have mentioned on your previous post I can’t use the link field in this case, in my main table I have 7 columns (Dest 1, Dest 2….Dest 7) link to the city in my other table to the get the corresponding local currency for each destination and as I have mentioned on the post I was getting the automation failure.

Thanks again for your quick response and I hope I don’t find more issues with link tables.


Good morning Rose, It seems that I have the same problem here:

I have a calendar in << Google Calendar >> with a lot of activities and what I wanted to achieve is to create new records everytime a new event it’s added in the Google Calendar, so… The TRIGGER worked well, it identifies all the activities but the problem starts when as an ACTION I try to << Create a Record >>.
I put all the fields like: Title, when it starts and when ends, the description, who created it, etc. I try to generate a preview but then the message about “insufficient permissions”.

I tried it in another ways changing the order of the fields but the same message keeps appearing…

What do you think about it?

4 - Data Explorer
4 - Data Explorer

For anyone else getting this error, check if your "Create a record" automation is trying to link a record using a Display "Name" instead of "ID". For me, the error came up after the automation had been running for a while without issue, so it was hard to track down. In general I try to keep my links as "ID" instead of the default "Name" but these seem to slip by. Not sure why the issue is permission-based, but this seems to solve it for me.

Screenshot 2024-04-10 at 4.42.04 PM.png