Airtable Cobuilder is here! Learn more about our new no-code app creation feature, powered by AI on the Airtable Academy

Re: Google Calendar automation - cannot parse date and time!

3816 0
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

Has anyone tried out the new google calendar automation?

I have two tables: timeslots and reservations. For the start and end date of the calendar invite, I use the lookup to get the times from the timeslots table. Unfortunately the automation doesn’t support lookup fields yet so I made a formula instead (it’s just the field name of the lookup).

When I test the automation, it fails! It cannot parse the start and end time. Any workarounds to this?

Screen Shot 2020-09-15 at 9.43.39 AM Screen Shot 2020-09-15 at 9.41.23 AM Screen Shot 2020-09-15 at 9.41.07 AM

18 Replies 18
6 - Interface Innovator
6 - Interface Innovator

When in doubt, “jiggle the wires”! Y’all, I was on a flight once that was delayed (of course) out of Chicago. The captain came over the speaker system, told us there was an “electrical” problem, and that he was basically going to “reboot” the airplane. Yep. Then we taxied down the runway and took off… AHHHHH!

Now, related, I just wanted to say I appreciate this post. I’m in the midst of doing the same sync/automation, and am so thankful to this community for being a step ahead of me!

5 - Automation Enthusiast
5 - Automation Enthusiast

I have made

I tried using google calendar automation.
The problem i am facing is that start time is picked up different and if the meeting time is 5pm the google calendar via automation is 8-9 pm .
Don’t know why. Checked all parsed info.
Please help

Here is a sample base and training video on working with time zones in Airtable:

It did not work.
Tried Set_TIMEZONE(), new time zone is set. but when connect it to Google calendar via Zapier or via Automation it picks up 5:30 hrs more.
I noticed that GMT +5:30 is my time zone
See the difference in the Zapier screenshot

Is the GMT Time Zone option turned on for your date field? If not, it’s possible that the automations always send times to Google as GMT.

oh my god. you won’t believe what happened just now.
now i know the problem.
I had VPN on. and due to which Airtable was booking at different time. When i Did DATETIME_FORMAT(SET_TIMEZONE({Start time}, ‘Asia/Kolkata’), ‘MM/DD/YYYY h:mm’)

I could see the difference in time.

i was wondering my Airtable is picking some other time zone. Later I realised its VPN.

Plus the GMT button "
Use the same time zone (GMT) for all collaborators" .
Now when disabled button with VPN its working fine.


5 - Automation Enthusiast
5 - Automation Enthusiast

Hey, I’m having the same issue: I can’t create an event based on dates in my table.
I need to create an event based on formula born date-times, and that didn’t work; but even now testing with normal date columnes (with hardcoded values) didn’t work as well.
It encounters an error:
< Unable to parse datetime: “” >
But there is definitely data in those columns.
Here is an illustration.

Welcome to the community, @Tomer_Eldor! :grinning_face_with_big_eyes: Were those dates added before or after you tested the trigger step? When building and testing an automation, the data collected when testing the trigger is passed to the next step, and that step’s test is passed to the step after it, and so on. In other words, if you tested the trigger with empty date fields, and then added the dates before adding and testing your Google Calendar step, that will explain the error. You’ll need to re-run the test on the trigger (and other steps leading up to the Google Calendar step) before testing that step will work.

4 - Data Explorer
4 - Data Explorer

I ran into this and was able to resolve it by changing my trigger:

Project Setup
I created an Airtable for meeting dates where the index column was a timestamp in local time. I then made 2 formula columns that calculated the start and end dates for a meeting in UTC; these columns were 100% returning dates, as I was able to go to the formula’s Formatting tab and format my formula’s output as an ISO date.

My initial trigger was condition-based (when status dropdown column is ‘scheduled’), and it could feasibly have applied to many records; I think Airtable’s problem here is something around trying to operate on an array of records as a singular record.

I added a Calendar View for ‘Scheduled Meetings’ based on my local time meeting date index column and filtered the view to only display records that have the status ‘scheduled’. Then I changed the trigger to being when a record enters the ‘Scheduled Meetings’ view. This fixed my issue.

Hope that saves someone else time :slightly_smiling_face: Someone from Airtable should also look into resolving this or making the failure reason more transparent; the error message itself is super vague (just tells you that an empty string ‘’ not being a usable date).