Slack Integration Always Fails- why?

Topic Labels: Integrations
954 1
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

I've been running into a frustrating issue, and there doesn't seem to be a clear solution based on the conversations I've had with the support team in the past.

On the surface, it sounds simple: Slack can't (or won't) authorize the Airtable integration. Tried to connect in all browsers. Tried changing my log-in process. Tried changing my Slack access. Nothing.

Looking at the Slack App Directory, it appears that users in our Slack instance are missing the authorization to 'send messages as Airtable'. Is there a way for me to add this authorization manually? Is there a simple solution that I'm missing?

Thanks in advance for your advice!

1 Reply 1

Hey @Ash118

If all of the users in your Slack organization are missing the the Send messages as @airtable authorization scope, then this might be something you should escalate to one of your Slack administrators or workspace owner(s).

If you haven't already, I would recommend forcing a new OAuth from Airtable and seeing if there might be an issue with the scopes when you're first going through the OAuth flow.