Help

Re: Update record with automation: record doesn't exist

1032 0
cancel
Showing results for 
Search instead for 
Did you mean: 
MSN
5 - Automation Enthusiast
5 - Automation Enthusiast

I have 2 tables (Table 1 and Table 2) in a base (Base B). I have created 2 automations, the second one is not working.

The records are created in Base A - Table 0 and synced to Base B - Table 1, so Table 1 is a synced table. 

  • The first automation works: When a record enters Table 1 (view X), a record is created in Table 2
  • The second automation doesn't work: when a record is updated in Table 1 (view X, all fields), update the record in Table 2

The error is: The record does not exist. I wonder whether the problem is the fact that its a synced record. The record IDs in Tables 1 and 2 are exactly the same, but Table 0 shows a different one.

Would anyone know how to fixt it? Thank you in advance.
 

3 Replies 3

Hi,
record ID cannot be the same in different tables. Every record receive it's own ID when created, and its unique. I think, you even cannot have 2 records with the same ID in your whole company with all Workspaces and Bases.
Record ID a string recXXXX , where XXX - random 14 characters, letter or number, case sensitive. You can see it adding a field with formula RECORD_ID(). Or if you extend the record by pressing space, ID will be visible in browser address bar, after view ID.

When you set up automation, you add record_id to the respective field. If you put this id in Table2 Update record step, of course it can't exist there.
I think, you should add 'child_id' column to Table 1 with ID of record in Table 2, and add to your first automation last step after Create Record (in Table 2), the step with Update Record (in Table 1), where you put ID of new-created record in that field. 
Records that already existing in Table 2, must be somehow linked to their respective 'parents' in Table 1, then you can temporary create formula field in Table 2, with RECORD_ID(), and reflect it in Table 1 via lookup. Then you can copy values to the 'child_id' field, and then delete link and lookup.

So when automation 2 is triggered, and you want to Update record in Table 2, under 'Table' field you have record ID field. Instead of putting there ID of a record in Table 1, you should put there a value of a 'child_id' field.

MalachizzBots
5 - Automation Enthusiast
5 - Automation Enthusiast

3rd party solution here, but with zzBots 1-Way Sync for Airtable your records will stay in sync and up to date in realtime. Any new or updated records in one table with automatically be synced to the other table. zzBots will automatically keep tack of which records are linked and update them accordingly or create a new one if none exists.

1-Way Sync: https://www.zzbots.com/store/airtable-airtable-1-way-sync

MSN
5 - Automation Enthusiast
5 - Automation Enthusiast

Thank you very much, Alexey_Gusev. I have to admit I have tried to do what you suggested, but with no success yet. I will try again in a few days time and, if I still have problems, I will contact Airtable HelpDesk.