Help

Updating a Status field between two sheets

Topic Labels: Automations Sync
627 3
cancel
Showing results for 
Search instead for 
Did you mean: 
Sasha2
4 - Data Explorer
4 - Data Explorer

Hi guys!

On one table I'm looking at Set Up Account details, and on the other I'm looking at Account Performance. The first pulls data from Typeform, the second from our internal system. To be able to tell how well the account is doing, I need the context of what stage of 'set up' the account is in, so I need the Status to dynamically update Performance, when it's changed in Set Up. 

I've tried to do a Linked Field, but it doesn't seem to be accurate, and now it's not working at all. I'm not sure whether that's the best solution? 

So I tried to automate it. The trigger stage is successful (attached), but then the Update Records stage fails with 'Received Invalid Inputs'. I'm matching the records based on our internal ID number that we update the fields with (ave_id). 

Any help or ideas gratefully received! Thank you. 

3 Replies 3

Is "ave_id" the record ID of the record you want to update in "Performance"?  If not, you need to use "Airtable record ID" instead

Screenshot 2024-05-23 at 9.58.49 PM.png

From what you've said it's probable that you should try to link the records together and use a lookup field for this instead.  If you could provide screenshots of the relevant tables and fields I could take a look at it for you

Sasha2
4 - Data Explorer
4 - Data Explorer

Thanks @TheTimeSavingCo!

In terms of the automation, yes, the ave_id is present as a column in both tables, and filled in. I didn't think the system would be able to know which record it was supposed to be updating, otherwise? 

In terms of Linking the records (which sounds easier, if it's possible!):

Attached is:
1) an image of the Linked set up in the Performance tab,
2) but as you can see from the screenshot it's blank. 
3) the column is filled in the Set Up tab

I just can't work out why it's not filling! And of course, the Lookup field is blank too, as the Link field is blank.

Thank you for your help @TheTimeSavingCo 🙂 

Thanks for the screenshots!  I'm afraid I still don't have enough information to help

Could you provide a read only link to a duplicated copy of your base with some example data please?