Re: remoteFetchAsync responses return wrong character encoding (fetch does not)

1442 1
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

When using remoteFetchAsync with my own server API the response.json() has clear character encoding issues:

Promoción desde solo 29€/día.

Calling the API in browser or Postman returns as expected.

I spent some time checking Headers in the request, the server response encoding etc… But when I used the normal fetch routing the API through the website it worked and returned the correct characters!

Is the server used in remoteFetchAsync not encoding correctly the response?

6 Replies 6
4 - Data Explorer
4 - Data Explorer

I have same problem. Wait for a solution …

5 - Automation Enthusiast
5 - Automation Enthusiast

I have just landed on this function today it worked for me! are we allowed to share codes here, if so share yours we can see what’s the issue is!

5 - Automation Enthusiast
5 - Automation Enthusiast

Thank you for bringing this to our attention. I think I have enough details to work on a fix, but if any of you have a sample remoteFetchAsync call for reproducing the issue that would be much appreciated

[ETA: I used remoteFetchAsync both in my code and edited the sample code as well. I also confirmed that the characters look fine if I just do my call in the browser…]

I seem to be having the same issue BUT I also tried this shared code example and it works successfully e.g. pullingÅland_Islands:

The (non-public) API I am working with has the exact same code but the accented characters are not coming through properly (“name: “Ã…land Islands””)

I am trying to follow up and see if there is something different I need to account for in how the API I am using delivers content…


5 - Automation Enthusiast
5 - Automation Enthusiast

Update: so the only work-around I have found is to move the script to an Automation where I can use fetch instead of remoteFetchAsync

Cannot figure out why didn’t doesn’t work for my API but does work for e.g. Wikipedia.

Please update if this is fixed as I would much prefer to have this as a Scripting App than a Automation. Thanks!

@Michele_Jenkins - this should be fixed now.