This Product Ideas board is currently undergoing updates, but please continue to submit your ideas.

Duplicate Table to Different Base

Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi AirTable Team,

Thank you so much for AirTable – it’s been so inspiring and helpful!

Feature Request: “Would it ever be possible to duplicate an AirTable Table to a different AirTable Base?”

Use Case: After creating a great Table with customized fields we realize, “This table would work great in another base we already have going. Let me just export it to CSV and Import.” While this gets us most of the way there, we lose the field type customizations in the process (i.e. Single Select, Multiple Select, Attachment, URL, Currency, etc.).

For now, I am happy to go back through the 18 fields (in our case) and customize each field type. Simply changing it to an “Attachment” or “URL” is no problem, but where it takes a little bit more time is in recreating or cleaning up the Single Select and Multiple Select options. We have a number of those fields and have to edit again, add, etc.

Idea for Implementation: Perhaps in the Table arrow dropdown we could enhance the “Duplicate Table” option that is already there so that, when clicked, it presents a new window that lets the user select which Base they want to duplicate this Table to. The dialogue/window might look similar to the one we see when we switch Bases by pressing Cmd+K: we can simply start typing the Base name with the ability to duplicate the Table to that Base. This might be one of many ways to introduce this functionality.

If the feature request ever makes it to the AirTable “Let’s do this” list, of course that would be exciting for me, but I know there are other priorities as well!

Thanks again for AirTable(!) and to the teams, friendships, and vision behind it – keep up the good work! :slightly_smiling_face:

4 - Data Explorer
4 - Data Explorer

Wow, wonderful @James_Hahn_II! Your patience and solution sharing is greatly appreciated!

6 - Interface Innovator
6 - Interface Innovator

Why doesnt this work for me? Formats and data are copied but not formulas? Any ideas?

4 - Data Explorer
4 - Data Explorer

You sir, are a rockstar!

4 - Data Explorer
4 - Data Explorer

Hi @ James_Hahn_II … great job - but it does not work on my end. May I ask what Windows and Browser you are using? Don’t really think it is that, but I tried all copy/paste “grips” I can think of.

And after two years of Airtable not delivering I don’t think they will.

But still @ Airtable it would really be cool to just add it as a feature to copy to another base or another table.

EDIT: Okay, so after giving it another whirl - yes, I just can’t help it - I think I found the missing link…
@Jason_Friedlander and @merlinregis_Thibeaul I may just found what you were trying to do

Go to the table you just created in the other base OR to the table you want to add to.
Then hit your “pasting combination” for MAC/Windows. That (often) prompts a pop up from Airtable asking you if you want to expand the table or keep it as is.
If you expand the data and the structure will be added.

Here is the kicker: When there is already data in the base, it may not or only partially expand with the columns and data. I think it has something to do with the ID column (all to the left, that you can’t delete or push somewhere else), but may also come with what columns are already in the base (say twice a date column or a notes column)

I am new to Airtable so my data is very limited at this point to really see what exactly the expand-feature triggers and when/how it does fully work and when not or partially.

4 - Data Explorer
4 - Data Explorer

Awww, shucks! Thanks @kyrie_gibson!! And happy to help @Jarret_Cassaniti :slightly_smiling_face:

Great catch Annie. I should have added I’m on a MacBook Pro using the Mac desktop app.

It’s hilarious I just got looped back here 47 days later. I loved the functionality of this community so much it stuck with me. Subsequently started noticing the same technology in use across the web. 15 days ago I had to know what was behind it… for anyone that’s curious it’s, an open source forum platform.

Haven’t slept for the past 15 days while I learned command line tools, Terminal, Ruby on Rails, Homebrew, Git, Vagrant, VirtualBox, nginx, PostgreSQL, Redis, Sidekick, and oauth2 with slight detours for Trellis, Bedrock, Sage 9, and Mailgun so we wouldn’t have to pay Discourse $300/month for hosting and access to all the plugins. Just finished writing a detailed tutorial over there, checked my email, and saw notifications from the Airtable Community. What a difference 47 days can make!!


p.s. Thanks for listening. Honestly never thought I’d be able to do this kind of programming and kinda (totally!) geeking out :grinning_face_with_big_eyes:

5 - Automation Enthusiast
5 - Automation Enthusiast

@James_Hahn_II you are blessed among men! Thanks for sharing this tidbit!

7 - App Architect
7 - App Architect

I’ve deleted all columns and rows in the new table, then Paste. But it still doesn’t copy the formulae - only the data.


After CTRL-V, only this pops up:

Do you want to expand this table?

To fit your pasted data into the table, we need to add 52 more recordsand 12 more fields.

Expand the table so that all of the pasted cells will fit.

Don’t expand the table. Values outside of the table will not be pasted.

5 - Automation Enthusiast
5 - Automation Enthusiast

This is a must. seems to also be a different thread for the same feature

4 - Data Explorer
4 - Data Explorer

Thanks James for sharing!

4 - Data Explorer
4 - Data Explorer

I’d also like to copy the views along with the table, to the new base.