Automation not triggered with two conditions (OR logic)

Hi

My automation behaves strange when using two trigger conditions. I created a very simple automation to demonstrate the bahavior.

  1. Trigger: When record matches condition
  • When “Force sync” is True
  • OR When “Time since last modified” > 600
  1. Action: Run a script (using default code)

Some explanation about the settings:

  • “Force sync” is a checkbox field. I use it to force the automation to start

  • “Time since last modified” is a formula field that calculates the time (in seconds) since the last modification of the record. The formula is

    IF(DATETIME_DIFF(NOW(),{Last modified time},‘seconds’)>1000000000,-10000,DATETIME_DIFF(NOW(),{Last modified time},‘seconds’))

The issue:

  • The automation isn’t triggered when the “Force sync” is set to true.

The cause?

  • Apparently it has to do with the formula field. If I change it to a Number field it works as expected. Then why is it now working with the formula?

KR Ashgard

Hey KR, I think I understand what you’re asking. Have you tried setting the default format for your formula to Integer? I think that I’ve had to do that before (maybe it’s an implied casting of the formula result to the format type).

Hi @augmented. Thanks for your suggestion. I checked, but I had the format of the formula already set to Integer. There must be something else causing this issue.

Would you mind taking a snip (pic) of your automation trigger conditions and replying here?

Also, check out this issue.

2 Likes

Thanks for the information. The issue you referred to indeed seem to explain my issue. I made the Last modified time field dependent on the Force sync field. That seems to solve it as it will cause both conditions to go to false.

Here is the screenshot of my trigger for later reference.

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.