Issue with CSV Import (it's occasionally creating new records instead of updating existing)

Hey All,

I use CSV import to update case management files and import new ones from a separate system operated by a partner of ours. CSV importer is mostly working but is identifying a lot of records as new when they should be updated instead. They are matching on a unique code generated externally from airtable. This is problematic because the cases are associated with different programs and that history is spread out when a duplicate record is being created rather than updating the original.

I’ve checked it by comparing October and November reports in excel. Working through excel (comparing unique codes), there are only about 60 new records out of 3500, while CSV importer is saying that there are over 350 new records.

Has anyone else run into this issue? I’m encoding UTF-8.

Edit: I’ve tried to slim the import down to just the records that have updates or are new, CSV importer is still saying 10 additional records are new that are not.

Wild hunch - 2 (or both) possibilities:

  1. The CSV importer process has some latency and caching ongoing as the data is ingested. This makes it possible for existing matching IDs to be construed as new when in fact, they already exist.
  2. The CSV data itself and which contains the externally-generated ID is not truly matching (trailing spaces perhaps).

Frankly, I did not know that a CSV import could be matched against anything except actual Airtable record IDs.

1 Like

You might be right, I tried uploading the file from last month (should match everything that is in the database currently) and CSV import is saying that 275 records will be created, which is super incorrect. Weird. Do you know offhand who to contact to alert to the issue?

Airtable Support - they’re pretty responsive to issues like this.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.