Attachments in Send Email Automation not Working anymore

Topic Labels: Automations
Jump to Solution
9863 36
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer


Airtable response: 

Our engineering team has successfully deployed a fix for this issue (which arose from a recent update to our code) and any automations referencing an attachment should now run as expected without error.

It's working again. Thank you all.



I've been using the Send Email action in automations for more than a year. Always worked great. In the Send Email action, in the Attachments section (Bottom) I selected the column that contained the file, and that file was attached in the email.

Captura de pantalla 2023-04-24 a la(s) 1.49.20 p.m..jpg

3 days ago, my automation worked fine. But today, when the automation triggered, there was a problem (An attachment url is disallowed):

Captura de pantalla 2023-04-24 a la(s) 1.53.48 p.m..jpg

I already turned off and on the automation, changed the trigger, changed pdf file for jpg, and always the same error.

I tried the automation with records that already triggered a few days ago and worked fine (My trigger is a Single select column, so, to trigger it again, I deleted the value in the single select field, and select it again). Same problem.

I already wrote to Airtable Support, but I wanted to write here too, because it is a very important feature in my workflow, and maybe one of you can help me find a solution or a workaround.

Thank you very much for your help.

36 Replies 36

I've just noticed immediately after posting that the URL field looks different now. 

Working version:

Screenshot 2023-06-08 at 10.35.53.png


Broken version

Screenshot 2023-06-08 at 10.36.14.png


I fear this has to do with this whole attachment change which is currently the bane of my existence, but I am alas a busy bicycle mechanic, not a developer so I really struggle to understand EXACTLY what the changes really mean, I just have to spend a couple days a month making workarounds!

Difficult to test fully at the moment, but after creating (ANOTHER) view, and (ANOTHER) formula, I seem to have my system back, - Thanks all, and support - for input and hope this helps anyone tearing their hair out (even after reading other posts)


5 - Automation Enthusiast
5 - Automation Enthusiast


We still experience this issue when using the "When a form is submitted" automation trigger.

The automation was created more than a year ago and the first error occurred on May 31st, 2023.


It could be a matter of simply re-creating the automation.

4 - Data Explorer
4 - Data Explorer

I still have this issue... only when somebody submit the form. Direct from base it's no problem to send email with attachments. 

4 - Data Explorer
4 - Data Explorer

I have been having issues with this lately as well. An automation that has been working for months just started giving the same error message. I reached out to support but no one has responded.

It seems that the issue was fixed for a day last week, and then today it started giving the same error message again. It's even worse this time because any trigger I have tried has failed (whereas we would always find a workaround previously).


I have tried deleting and re-creating the automation but no luck. Please fix!

I also have 1 automation (out of hundreds) that has been failing with the “attachment url disallowed” error again for the last week or so. Luckily, it is a somewhat irrelevant automation for our operations, so I actually just removed the attachments for now. The only thing I can think that is different than any other automations is that the attached file is usually a phone-captured image, so it is decently large. But I have other automations where it emails up to 25mb files so I don’t think that’s the problem.

Anyways, I’m just lucky it is one not-important automation, but the issue seems to persist. Hopefully support gets back to you.

5 - Automation Enthusiast
5 - Automation Enthusiast

The problem is absolutely not solved !

"An attachment url is disallowed" error blocks all my email automations, 
please help

4 - Data Explorer
4 - Data Explorer

Same problem here! Anyone can help, please?

4 - Data Explorer
4 - Data Explorer

I'm also still receiving this error message on a very important automation. It seems like a delay/wait action would resolve the issue. Airtable team- are you still working on this?